Volvo Owners Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Just to say, I finally took the plunge to join this forum. I've got a 3year old S60 2.0T and I would be grateful for any tips about getting the most out of this beaut.
 

·
Premium Member
Joined
·
8,352 Posts
Welcome, philipoi!

 

·
Premium Member
Joined
·
1,720 Posts
Congratulations. Firstly for buying a Volvo and then joining this group.

If you can't: drive type or spell-doubly welcome


As for your question: to get the best out of your car:

Volvo service it
clean it
get the best petrol you have in the country


Drive it as if you are showing the next owner how you drove it.

Keep in touch with this forum. Cheers and Welcome
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Thanks for the tips. I am finding a few glitches in the car, nothing major, but irritating, like the petrol cap dropping out, and creaky noises from the front wheel. All fixed by volvo. The creaks apparently due to a loose link rod? The volvo guys said they replaced that, and tightened the chassis (?). Now, the car doesnt seem to accelerate as quickly (like the handbrake was still up), but the guys said there was nothing wrong with the acceleration. Is there something I am missing, or am I just getting used to the car? I used to feel it move smartly even at low revs (2200), but now it only moves when I step it up to 2500 and beyond. I thought the manual said that you would get max torque at low revs. Any comments?
 

·
Premium Member
Joined
·
8,352 Posts
I am moving this thread into the S60 Forum, for better exposures.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
Thanks S60R. According to the sales blurb, 240nm at 1800-upwards. I am wondering if the Volvo boys have reset or adjusted the computers on board. Can they do this? I have also noticed my average fuel consumption has moved up just a bit from 8.9L to 9.2L /100km after the service, without much change in the highway/town driving style.
 

·
Registered
Joined
·
2 Posts
Hello There

I also have a 2.0 t but the 2005.
When i took delivery the car seemed to go really well but once the dealer loaded the newest software the car seemed to be a lot less resposive.
There seems to be less "pull" from the motor.
Mixing fuels of various brands seems to make it worse.
I had the throttle body adaption values cleared and this improved the situation some.
I still think the new download is a problem but cannot get volvo to listen.
Enjoy the car.
 
1 - 12 of 12 Posts
Top