Volvo Owners Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Question and in need of help?

Hey everyone I'm looking for some input that can help guide me to a solution.

I just got my brand new S-60R. It's very very nice. Changed for a Subaru WRX STI. Loved that one as well. Great cars.

Anyway, I bought the car with U.S. specs. in France and the Nav. system is driving me nuts. Before I take it to the dealer (language barrier) I was hoping that someone could help me. I get voice guidance whenever the system feels like it. Sometimes it works and sometimes it doesn't.

When I first called Volvo here in France I was told that it's because I bought the car with U.S. specs and I will get the U.S. DVD map with voice guidance when I go back to the U.S. However, that is incorrect because I have received voice guidance in the past. So, I called the Volvo dealer in the U.S. to verify. They told me that it could be a retailer problem with the DVD. I should clean it and try again and if it doesn't work have my local dealer order a new one.

Can anyone help me? My next step will be to go the dealer. I', curious to see what they have to say. Maybe it's something simple andit's just plain user error.

Take care and this forum is great!
 

·
Volvo Guru !
Joined
·
5,908 Posts
I know that sometimes the NAV messes up if to many past end points are left stored in there.

Have you tried emptying all the history in the NAV?
Sometimes that might help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your prompt response. No, I haven't tried that yet. I will try it as soon as I get a chance.

Thanks again.
 
1 - 3 of 3 Posts
Top