Volvo Owners Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a problem with my v40. During long trip (after my engine gets hot) when i change speed for eg. from 3th up to 4th my car goes not as smoothly as normal and I have to wait a while to get a normal power of my engine. I replace a air and fuel filter . All the basic checks and inspection seem OK Has anyone had similar issues and fixed them ?

kogut
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
QUOTE(Tech @ Feb 22 2005, 06:24 PM)Have you changed the spark plugs lately?Is there a check engine light on?
[snapback]3809[/snapback]​


I bought this car 10 days ago and I have not changed the spark plugs lately. I do not know if last owner has changed it. I have changed the timing chain (belt) recently.
My check engine light is on. Can you help me ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
I bought this car 10 days ago and I have not changed the spark plugs lately. I do not know if last owner has changed it. I have changed the timing chain (belt) recently.
My check engine light is on. Can you help me ?
 

·
Volvo Guru !
Joined
·
5,908 Posts
You will need to have someone hook up a scanner to the car and pull codes out of the car.Then it will give you an idea of where to go.If you have an Auto Zone or Advanced Auto Parts near you they pull codes for free.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top