Volvo Owners Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Love the S40 but trying to work on the minor bugs. I have an issue where about 70% of the time it takes 3 sec or so to start. It doesn't matter if it's hot or cold (engine or outside). Tech, I tried swapping the key positions around and it did not work. What is the screen/shield that you and others refer to? Is this a part I can put on or is it a special dealer install? If dealer, how much U.S. $? Thanks.

Kyle
 

·
Volvo Guru !
Joined
·
5,908 Posts
It is a part you can buy from the dealer and install your self.
It is called a speed sensor sheild.
If they look at you funny when you ask for one let me know and I will try to get the part # for you.
 

·
Volvo Guru !
Joined
·
5,908 Posts
You can buy one from the dealer.
The engine speed sensor sends signal to the computer to allow the car to start.
The sheild gets installed to block interferance from other componants to the sensor.Which without the sheild that is what causes the car to crank a little more before starting.
 

·
Registered
Joined
·
3 Posts
I wonder if this will help with my issue? When I turn the key to start my car at random times (usually after sitting) it will try to start, shudder and die. The 2nd time it will start. Will this Speed Sensor shield fix this problem? The shop I go to has no ideal what it is (they said it may be a software issue).
 

·
Volvo Guru !
Joined
·
5,908 Posts
QUOTE(WhiteS40TGirl @ Jun 29 2005, 08:17 PM)I wonder if this will help with my issue? When I turn the key to start my car at random times (usually after sitting) it will try to start, shudder and die. The 2nd time it will start. Will this Speed Sensor shield fix this problem? The shop I go to has no ideal what it is (they said it may be a software issue).
[snapback]10654[/snapback]​


It could help.Or you have a weak fuel pump.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Tech, if you don't mind could you please give the part # for the speed sensor shield? I went to the dealer part counter today and they said they didn't know what I was talking about. Thanks!
 

·
Volvo Guru !
Joined
·
5,908 Posts
No I couldn't find it.I can believe the dealer does't have it.They must really suck!!!
 

·
Registered
Joined
·
2 Posts
Regarding the starting difficulties, my 2005 S40 T5 has the same issue. It seldom starts on the first try, and it does shudder as you describe.
My temporary solution is to crank it over for only a second or 2, then turn it off. The engine starts immediately on the next try. This is definitely not a solution but a temporary bandaid. I would sure like to hear the real solution.

Thanks
 

·
Volvo Guru !
Joined
·
5,908 Posts
QUOTE(dallashouston @ Aug 11 2005, 08:03 PM)Regarding the starting difficulties, my 2005 S40 T5 has the same issue. It seldom starts on the first try, and it does shudder as you describe.
My temporary solution is to crank it over for only a second or 2, then turn it off. The engine starts immediately on the next try. This is definitely not a solution but a temporary bandaid. I would sure like to hear the real solution.

Thanks
[snapback]13352[/snapback]​


Your car is a whole new bread and has a totally different setup.
 

·
Registered
Joined
·
39 Posts
I had similar starting issues with my S60. It turned out I had a cracked fuel pump that the dealer replaced. All is well now.
 
1 - 13 of 13 Posts
Top