Volvo Owners Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2012 S60 and the driver and passenger seat heaters do not work. When I push the button to turn the heater on, it looks normal and I can select the three levels. I do not have a DICE interface but I do have a Foxwell Scanner with the Volvo firmware. I receive two error codes in the CCM:
B10874A and B10884A. Both of these read out as LIN bus int failure - Incorrect Component Installed. The Seat Heater Modules are the originals and no other components were changed.

I disconnected and reconnected the battery and ran the diagnostic and did not receive any CCM errors. When I pressed the seat heater buttons on, I then received the same errors.

Any ideas?

Thank you
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Update:
I used the Foxwell Scanner to run the Calibrate Function for the CCM. After doing this the seat heaters work! I believe during the calibrate it looked for devices attached and found the missing Seat Heater Modules.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Curious as to why the modules were deemed missing in the first place. BTW, which Foxwell scanner are you using?
It was strange since both seat heaters were not working so somehow it lost communication with both of them.. I have the Foxwell NT530 with the Volvo firmware and found that it works well. I like it since we also have a Toyota and adding the second make is about $70.
 
1 - 5 of 5 Posts
Top