Volvo Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have 2 problems which I think are probably linked.

1. once a week or so, car fails to accelerate, will keep going at same speed (doesn't cut out or anything), but just won't go any faster. Talking between 40-65mph. Clears after a 30secs to 1 min.

2. every time I go out, there is some juddering under acceleration. This isn't every time I accelerate, just one time in five say. Think this is the engine rather than the wheels.

A friend has suggested the fuel filter as a possible cause, although this was changed at last service at 70k (now done 77k).

I almost always use good quality diesel and avoid supermarket stuff.

Any diagnosis much appreciated.

If it is the fuel filter, where is it and is it easy to change?

Many thanks.
 

·
Volvo Guru !
Joined
·
5,908 Posts
The might be software for the trans. Not 100% sure but then the engine might new software upgrade.
 

·
Registered
Joined
·
9 Posts
I'm thinking I might have a similar / same problem on my '02 D5 S60 (50,000 miles)

The car judders at around 50MPH, if I'm in 5th (auto). More noticebly if I'm going up hill - almost before it kicks down. If I drop to 4th, it'll go away. Recently I noticed it in other gears at other speeds (30 in 3rd). Very worried thinking maybe the transmission if on the way out?

Was at the lights the other day, and slipped it into Neutral - bought the revs up to 1300 - 1700 and there was a deffinate judder there. Outside of that rev range, it's fine.

So Good news, it's not the transmission - bad news, it's something wrong with the engine!

I've had the transmission firmware upgraded to get rid of the rough idle and hesitant pull off from stationary - that worked fine.

Any ideas though? I'm wondering if it's a missfire / injector? But I don't have any warning lights on the dash - engine mounts maybe?

It's due a service in 1000 miles, so I might kill two birds with one stone and get it hooked up to the computer at the dealer.

Hope it won't break the bank!

Olly.
 

·
Registered
Joined
·
9 Posts
OK, so we're pretty much sorted now.....

60k service
4 new injectors
new fog lamp
Bushes
+a few other bits!!

and £2,200 worse off!!

OUCH!!


Anyway - all was well, but now I have a faulty Exhaust Gas Recirculation Valve, and have a slight roughness back again at 1800 RPM. That can wait until next month i think!!
 
1 - 6 of 6 Posts
Top