Volvo Owners Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
hey tech,

The passenger rear door lock starting making a funny sound when locking the car and today it quit working altogether, now it wont lock or unlock the door at all. how hard is it to replace and where can I get one?

thanks
 

·
Volvo Guru !
Joined
·
5,908 Posts
Im not sure if you can find one in the aftermarket yet.I don't think anyone makes them yet.You will either have to buy a new one from the dealer or find a used one.

They are pretty easy to replace.
 

·
Registered
Joined
·
26 Posts
Hi Used S80

I am new to this forum and first time Volvo owner. I have a three and a half year old S80 and had it for 3 months now. Since then I have had both front and a rear central lock motors replaced because these would not respond to the remote. These were replaced under warranty so they were not left until it had stopped working.
According to Volvo this fault is very common on this model and Volvo know about it. Any cars that are over 3 years outside of warranty Volvo would pay for 50% of the work, perhaps you need to find out.
 

·
Volvo Guru !
Joined
·
5,908 Posts
Another thing about these locks and why they go bad is because people keep spraying lube into them.Then lube works down into the lock and causes it to go bad.
 

·
Volvo Guru !
Joined
·
5,908 Posts
Most of the time when people do oil changes they lube the hinges and the latch so everything moves good.Well you can lube the hinges but don't lube the latch on the back of the door.The latch and the lock assembly are all one peice.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
thanks for all the info. I will look into the out of warranty thing with volvo dealer. but if its a no go at what places could I check to get a used one?
 

·
Volvo Guru !
Joined
·
5,908 Posts
You would have to find a salvage yard that has a wrecked one.
 

·
Registered
Joined
·
13 Posts
I've had this problem as well, where the rear driver's side door lock doesn't work. I got a used spare and fitted it (not that easy a job, tech!)and it worked fine for about a week and then packed in again. It only does this when the weather is cold, so I guess with the winter coming on in Norway I'll have to put up with it for another few months. Volvo do not know the answer to this apparently. I think that it is the fancy electronics in the sender unit which causes the problem. Why not have a simple motorised unit like the V40 models have? Something to do with security I was told... I was also told to spray WD40 into it...

I don't think there was anything wrong with the first lock either, so I replaced it for no reason (for about 60 quid). So now I have a spare!
 
1 - 10 of 10 Posts
Top