Volvo Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
I also have the same problem with my 2004 S-40, it will drive good and accelerate fine when the outside temp is between 30-60 degrees, but here in fla it gets very hot in the summer and then the s-40 drives like a turtle I have taken it in to the dealer but they say there is nothing wrong with it. they just drive it around the block and don't give it a chance to heat up
I got stuck with a lemon... and will never buy a piece of crap Volvo again!
I always use 93 octane fuel.
I have tried a K&n air filter bit it didn't make any difference
Also using 103 octane boost didn't help either. Like I said the car is crap!!!
I just wish I still had my Honda...

ONE UNHAPPY VOLVO OWNER!
 

·
Registered
Joined
·
4 Posts
QUOTE(jdlar53 @ Feb 13 2005, 12:01 AM)I also have the same problem with my 2004 S-40, it will drive good and accelerate fine when the outside temp is between 30-60 degrees, but here in fla it gets very hot in the summer and then the s-40 drives like a turtle I have taken it in to the dealer but they say there is nothing wrong with it. they just drive it around the block and don't give it a chance to heat up
I got stuck with a lemon... and will never buy a piece of crap Volvo again!
I always use 93 octane fuel.
I have tried a K&n air filter bit it didn't make any difference
Also using 103 octane boost didn't help either. Like I said the car is crap!!!
I just wish I still had my Honda...

ONE UNHAPPY VOLVO OWNER!
[snapback]3297[/snapback]​


I used to own a 03 40 and had the same problems in high temperatures, slow accel. Hot air will kill your turbo`s ability to make power something to do w/compression. Try to get a bigger intercooler http://texasautomotiveperformance.com/ sells a great one worth the investment 25hp gain dyno proven.

For more hp gain hang around http://s40concepts.net/ Plenty of tricks there.

As for Hondas i hate them. Ugly cars that are not even that reliable anymore. New accords need auto tranny swaps about every 30 thousand miles.
Girlfriend had a coupe and it was a very troubled car.

streering wheel controls stopped working at 1000 miles

cd player skips w/the smallest of pot hole much worst than the 40`s cd player

Slow in city traffic for a 245hp car. Leaves you flatfooted

key fob left her stranded 2x, 15000 miles, within weeks problem w/receiver in car. The dealer would not refund money spent on new key fobs, even though they were purchased because of a failure of a warrantable item.

Car failed to start after a couple days of rain. dealer replaced alternator 17ish k miles

Car stalled on the Bronx river parkway during a rainstorm dealer replaced alternator as well as a few other things not sure wich though 18k miles

Last but not least transmission gave up 28k miles. Turns out that it is a very common occurrence for this car. Turns out that it wasn`t made to handle the 245hp of the 6 cyl.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top