Volvo Owners Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
" hi all , i,m new to this board and really hope someone can help.
i have a 940 se turbo ,n reg , auto .
whilst driving i noticed that the engine had got noisier , it just sounds like the fans going round all the time , the temperature gauge is normal and no warning light are coming on . today i noticed fluid (large puddle) just under front bumper , drivers side , have checked under bonnet , but nothing , everything looks normal, fluid is clear , has no smell , and is shiny , could be water or could it be something else.
Can you give me any ideas as to what the problem could be ,

thanks
andy.
( since writing this post last night ,) this morning , the cars idling erratically , temperature gauge is on the red and emission system warning light has come on . refilled with water can,t see anything dripping , when i looked through the grill i can see fluid under the radiator on flat metal plate . Can i still drive the car .
HELP PLEASE .
andy.";
 

·
Volvo Guru !
Joined
·
5,908 Posts
The radiator might be leaking.
I don't reccomend driving it till you know for sure.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
thanks tech , going tocheck all hoses and will check radiator for leaks,
if i can,t find anything obvious i will get the proffessionals out ,

will let you know how i get on.

andy
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
hi ,
have checked all hoses and radiator , to my dismay have found leak in bottom corner of radiator , could,nt be something simple like a hose , bet its going to cost a fortune . will have to get professionals in , things have gone from bad to worse , as i found a small drip of brake fluid coming from the master cyclinder , i think someone has cross threaded the nut on the master cylinder , brake warning light is on , only had the car for 6 weeks , should have known it would all go wrong at the same time ,
i,ve decided to go for full service and repair .
peace of mind i think .

thanks for your help .
ps , is the emission warning light related to radiator leak or am i going to find something else wrong ??
andy.
 

·
Volvo Guru !
Joined
·
5,908 Posts
You might find something else wrong.Could be as simple as a vaccum leak.Or could also be a bad coolant temp sensor from it overheating.
 

·
Registered
Joined
·
3 Posts
hey, try to make sure ur radiator fan is in good working condition and would recomend filling up ur radiator with about 3 liters of coolant. 940 full turbos are very heaty engines. I had a radiator blowup when my radiator fan didn't function as well as it should. Temp on the gauge showed normal.
 

·
Registered
Joined
·
31 Posts
QUOTE(940rider @ Jun 13 2005, 05:30 PM)hey, try to make sure ur radiator fan is in good working condition and would recomend filling up ur radiator with about 3 liters of coolant. 940 full turbos are very heaty engines. I had a radiator blowup when my radiator fan didn't function as well as it should. Temp on the gauge showed normal.
[snapback]9573[/snapback]​


Oh F***!! Now you've got me worried, 940rider. My temp gauge shows nothing but 'middle' all the time! Fingers crossed that my e/fan IS working now.
 
1 - 8 of 8 Posts
Top