Volvo Owners Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
just got a 1991 940 and I'm not familiar with volvo's.
anyone have any links to wiring diagrams/manuals
it's running rough, Ok I'll clean the TB but where is the Idle motor?
 

·
Volvo Guru !
Joined
·
5,908 Posts
The idle motor is under the intake manifold.It is in a bracket that goes from the intake to the block.It has 2 hoses and a plug that goes to it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
OK found the motor it works ok when i give it power(from ajustable power supply)
engine still wants to die at tickover,
disconecting Idle motor makes no difference, I asume it should?
 

·
Volvo Guru !
Joined
·
5,908 Posts
In the air filter housing is a mass flow sensor.Try unplugging it and starting and see if it idles any better.It won't run very good off of idle.If so clean the electrical plugs good and connect and see if it helped.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
also disconecting the amm makes it run at fast tickover quite smoothly
I measured the amm and got 3.5ohms between pins 3-1, and 3-2
so I assume it's working OK
 

·
Volvo Guru !
Joined
·
5,908 Posts
In the air filter housing is the massflow sensor.Unplug it and try to start and see if it idles better.It won't run good over idle.If that helps clean the electrical connections good.If it doesn't help plugged back in the massflow is bad.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
started with amm disconnected, I then reconnected the amm and got a good fast tickover, then disconected the idle motor no effect.
started with amm connected, bad tickover again?
 

·
Volvo Guru !
Joined
·
5,908 Posts
Try cleaning both connections really good and installing dielectric grease and see what happens.You might have a dirty connection at the mass flow sensor.Sometimes they get bad connections and you clean it and grease it works fine for a while.
Sometimes the connections are critical.
Also check your wiring harness for the insulation falling off.

Sorry I just realised I double posted before some how not sure how though.
 

·
Registered
Joined
·
15 Posts
the connectors looked clean and not sensitive to movement
some of the wiring has lost its outer covering but inside seems fine
I thought it was only the older vovlo's that had this insulation problem.

anyway the car running better today but i have disconected the engine breather and blocked the breather inlet to the manifold.

I think cyl 1 piston has lost it's rings
to make matters worse that sparking plug is jammed solid so I
can't check that plug for oil , got it to move a 1/8 of
a turn or so, but am afraid of breaking it off.

Could a 244 engine be fitted to this car (1991 940 GL )
 

·
Volvo Guru !
Joined
·
5,908 Posts
Yes you just put your manifold on and you are good to go.They should be the same engines just diffrent type of fuel system.
 
1 - 14 of 14 Posts
Top