Volvo Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi there this is my first post on this forum. I have been with brickboard for some while and am here searching for the cause for an unexplained loss of coolant (slow) on my '98 S70 20V.
I live in Toowoomba Australia.

The car has been good to us so far and I do all the regular maintenance items etc.
since purchasing it at 125000 klm it now shows 161000 klm. Running Mobil 1 engine oil and have changed ATF twice (flushed at first) then just drop what is in the pan.

Cheers, Phil
 

·
Volvo Guru !
Joined
·
5,908 Posts
Welcome to the forum.

Have you pressure tested the cooling system yet?
 

·
Volvo Guru !
Joined
·
5,908 Posts
You would have to purchase a coolant pressure tester or have a shop that has one pressure test it.

Can you see any coolant leaking anywhere?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
No i have checked thoroughly with powerful light and checked under the floormats for signs of a leak from the heater core as well and nothing. Have replaced the original grey cap with a new green cap. No sign of coolant on the garage floor either. A poster on brickboard suggested it might be the radiator, as replacing his cured his slow coolant loss. I can't see any evidence of a leak at the radiator either, and it would be around AU$400 just for the new part. I'd like to be sure it's the radiator before parting with that sort of money. It's got me baffled!
 

·
Volvo Guru !
Joined
·
5,908 Posts
You need to have it pressure tested to help find it.Some times you can use a blacklight to help you find it as well.
 
1 - 6 of 6 Posts
Top