Volvo Owners Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Hi again everyone,

1986 Volvo 240 Wagon

I've replaced the ICU (the Programa type ICU seems to be more rare and consequently more expensive than the Bosch so i've reluctantly paid $135 for it) as i need to get this sorted out, anyway i've put the new ICU in and i'm still having same problems, this morning (only 1 day after fitting new part it woudn't start) perhaps i should look at more basic solutions;

Last week the after the car stopped and the battery went flat after turning it over for 30 minutes i called the RACV. The call out guy looking at the car couldn't work out what was happening, he said there WAS enough fuel getting through but here is no spark, no spark at the coil either i think he said, like nothing was getting through... a fuse perhaps?

He was orgainising the tow truck i gave it another turn over (the battery was fully charged again so had plenty of juice it it, i was completely surprised and releived when it started!... somewhat a waste of the $170 to join RACV on the spot and have the patrol come out BUT is has given me somemore clues i suppose.

I'm not sure what to look for now, ANY advice as to why the car would stop intermittantly will be really gratefully received some ideas i've considered are battery hasn't enough juice to give the engine spark (though it seems strong enough), the distributor might need replacing? The coil? The alternator (or would the battery just run completely flat after a couple of days if this was the case? Perhaps the 'NEW' ICU isn't working either?

Thanks guys for all you help! :]

p.s. the headlights seem to come on only after a 5-30 second delay also once switched on? Seperate issue but could be connected, will look at fuses, distributor contracts now i think.
 

·
Volvo Guru !
Joined
·
5,908 Posts
First make sure all the fuses are clean.
Sometimes the fuses will get dirty and loose connection.
 
1 - 2 of 2 Posts
Top