Volvo Owners Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hiya i have a problem with my mums volvo 740 Gl i think its a 2L or a 2.3L. H Reg a while ago the cambelt snapped on it so i replaced it and repaired the damage 1 new valve, guide, spring ect. i then rebuilt it using all new gaskets the car ran ok for a while and then suddernly stopped it was sparking but not putting any petrol through the injectors and then after trying to bleed the system the spark stopped it turned out i needed a new coil and fuel pump. i got these from a scrap yard. it still wouldn't run properly so it took the air deflector plate off (that increases the injection rate) cleaned all that up since the plate was sticking. know it will run but when you rev it too say 6,000 rpms it won't just rev out and cut back a little it kicks back down to 3.000 for a couple of seconds and i can't seem to get it to idle properly it will just run about 1100 rpm but not very smoothly and only starts running smooth at around 3.000, i tried changing the distubutor timing but that dosen't make much different. also i don't have a clue witch way the injector lead sequence goes i've been putting the leads in at a clockwise rotation from the fuel distrobutor but i don't know witch lead fires first, the pressure seems to be ok at the fuel distrubutor, and the spark it gives out seems to be ok i don't think i have any vacuum leaks. i think the car uses a continues injection system and is very simple it only has a couple of sensors, knock sensor, coolant tempature ect no lambda sensor. PLEASE HELP i've spent hours fiddling with the car. Cheers Sebastien.
 

·
Premium Member
Joined
·
8,352 Posts
Welcome, Sebastien.

 
1 - 5 of 5 Posts
Top