Volvo Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
1993 850 2.5 non turbo B5254s 20v.mileage 122k.Ran great till we had engine detailed.Dont know what he did but when i picked up car check engine light was on and ran erratic,barely reaching home.Read codes 5-1-2.Oxygen intergrator at maximum lean running limit.Please help
 

·
Volvo Guru !
Joined
·
5,908 Posts
If you have some tools remove the upper cover and then the spark plug wires and see if they got water in the spark plug holes.If so dry it out and see if it runs better.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hello,yes cover was removed and plugs were changed.Its also been really hot here so I thought it would dry out by now.Detail was done 2 weeks ago.Could it be a vacuum hose blown off?What does the oxygen intergrator do and where is it located?Thanks!
 

·
Volvo Guru !
Joined
·
5,908 Posts
Usually when that code comes up it is a bad O2 sensor.
It means either the front or rear one is bad.But also check the vaccum lines really good it could also throw the code.
 

·
Premium Member
Joined
·
773 Posts
QUOTE(Tech @ Jun 11 2005, 08:09 AM)If you have some tools remove the upper cover and then the spark plug wires and see if they got water in the spark plug holes.If so dry it out and see if it runs better.
[snapback]9444[/snapback]​


also if detailing involved water sprayer around check dist cap as even small condensation can couse such problems

and if all all else fails, seeing yo in buffalo, do a crash test dummy in the good old volvo spirit and drive off Niagra to see if modern volvo still as good at crashes as the old 144s
 

·
Premium Member
Joined
·
8,352 Posts
QUOTE(The Doctor @ Jun 11 2005, 08:38 AM)and if all all else fails, seeing yo in buffalo, do a crash test dummy in the good old volvo spirit and drive off Niagra to see if modern volvo still as good at crashes as the old 144s

[snapback]9459[/snapback]​


I see the good IT-engineering doctor is up to his normal self again.


By the way, I would concur on the vacuum hoses due to experience. There are a few and make sure they are all tight. Took 2 weeks before it finally disappeared, and we located the hose near the Turbo air intake was cracked.

Good luck!
 
1 - 6 of 6 Posts
Top