Volvo Owners Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
ok so when i got my volvo it was winter and cold engine ran very strong. lately i have finally done complete tune up, wires,plugs(ngk)cap and rotor...smoother engine now. i replaced fuel filter and air filter, engine runs well as it has gotten warmer out i have noticed a hesitation under part to moderate throttle, full throttle sometimes.....feels like a little rich in a carbed engine. i thought fuel pump but it runs very strong when cold, engine warms up then it starts in. still runs fairly well and reliable...cruisin at any speed i fine just acceleration problem. i checked for vacuum leaks cold and hot with carb cleaner none found. i heard fuel pressure regulators go bad with high milage so i replaced it. it actually diminished the problem but not gone. i am thinking temp sender for ecm? but i don't want to throw alot of money in parts at it. any help would be great.
 

·
Volvo Guru !
Joined
·
5,908 Posts
Have you cleaned the throttle body lately?

Could also be a bad coolant temp sensor.

How new is the mass flow sensor?
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
mass air flow sensor?...probably original 200,000 mi. have not cleaned throttle body.
 

·
Volvo Guru !
Joined
·
5,908 Posts
The mass flow could be bad but also try cleaning the throttle body and idle motor and see if it helps.
 

·
Registered
Joined
·
35 Posts
ok so i cleaned the throttle body spotless. i also changed the temp sensor for the computer. i checked the cbv and it seems to be working ok. still have problem. is there any way to check the mass air sensor before purchase? they are spendy!!!

ok also i noticed it is probably a lean condition, like if i am driving and trying to accelerate as long as i keep the engine out of turbo range on my gauge it accelerates smoothly but it is pokey, as soon as you go into turbo teritory it runs like crap. if you hold trans in gear it runs with hesitation untill about 3000-4000 rpm then it starts pulling pretty well at this point you can mash the throttle and go like hell. it's like the turbo is coming online with too much boost too soon. the weird thing that happened when i checked out my cbv(compressor blowofff valve)before i checked it the engine ran as first posting after putting a vacuum on it to check out it runs very rough....
 

·
Volvo Guru !
Joined
·
5,908 Posts
Another thing to look at is the rubber turbo hoses.Makse sure they aren't collapsing while under hard acceleration.Feel then and see if they are very soft.
 

·
Volvo Guru !
Joined
·
5,908 Posts
Im not sure where to go from here.
I will keep brainstorming.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #9 ·
could intercooler hoses with leaks cause this problem? i was just wondering...thanks for all your help...dan
 

·
Volvo Guru !
Joined
·
5,908 Posts
Yes I believe they can.That was one of the things I suggested to look for.That would be unmetered air and would make it run crappy.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #11 ·
ok you got me there, i had previously visually inspected all the hoses but i decide to give them a re-check by feel . SUPRISE!!! i found two of my inter cooler hoses bad one had just a pinhole the other had a flap about two inches square on the under side if the hose that was leaking alot...i am amazed it even ran. so in short i replaced all my hoses and now i have a road rocket!!! thanks for all your help....dan
 
1 - 13 of 13 Posts
Top