Volvo Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I pulled the vacuum pump from our 76 245 wagon today and found it full of debris and caked with residue. Any thoughts on why? I am having a hard time splitting the diaphram apart. Anyone ever to do this with success? The car has poor idle control until it warms ut and then seems to miss/backfire with carbon deposits coming out of tailpipe. Any suggestions? I have ordered tune up parts, hoses and the rebuild for the pump. Thank you. George
 

·
Premium Member
Joined
·
773 Posts
well I assume this is fuel injected? and not a carbie model?

if so I can help with KJetronic but I have no idea what a vacuum pump might be

vacuum comes from engine and not a pump so can you please explain the question because if just a warm up problem I should be able to help
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
Doc,

Yes this is a CIS model with a pump mounted on the head that is activated by the cam. It is mentioned in the Haynes as a vacuum pump. Haynes also says that not all injections models have them. I am assuming that it is not the culprit with the poor idle. The idle issue is: Car starts and wants to quit without constant throttle. after a few minuted of gradually backing opp the pedal it is more likely to continue running and sometimes has a sort of "ping" sound backfire and smells very rich. I should mention that I dumped some RED LINE fuel system cleaner in. Thanks for any advice. I ordered the rebuild parts for the vacuum pump on the http://www.thevolvosite.com/shop/index.php...4&car_model=240 George
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #4 ·


Rebuilt the vacuum pump, changed the vacuum lines and gave a tune up with new fule filter and it just purrs...
 
1 - 4 of 4 Posts
Top