Volvo Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone,
Recently i have noticed some strange problem with my 97 s40. Since one week i can't feel that this car performs abs self-diagnostic procedure (the brake pedal doesn't bump when i start and drive over 40 km/h). Dispite this, the ABS warning lamp goes off after 4 sec. I'm also no sure but the braking modulation isn't as good as it was before. Brakes work like on/off. Does this problem look familiar to anyone?
 

·
Registered
Joined
·
16 Posts


I had some damage with my ABS too. Once i have turned on my park brake on the speed of 10 mil/h. When i tryied to take it off the park brake, it has taken off, but the ABS lamp on the panel has appeared and ABS taked off. After that moment it ended to work. I mean the ABS lamp is burning, but ABS is not working. Maybe anybody had the problem with burning ABS lamp and not working ABS system? What should i do, why this problem could appear? How to do the self diagnostic for ABS system? please suggest me, should i drive to the retailer or i can fix this problem by my self? is this a big problem?

Thanks
 

·
Registered
Joined
·
1,348 Posts


Sorry to say that if the ABS warning light stays on then unless it's an ECU software fault (unlikely), there is a fault in one of the wheel sensors or the (expensive) ABS unit. You can buy reconditioned ABS units but you need to be a confident home mechanic to tackle the job.

Good luck.

BB
 
1 - 4 of 4 Posts
Top