Volvo Owners Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1999 S80 T6 with 75,000 miles on it. Recently, my abs and stc stopped working. This is a bit of a problem during a Michigan winter. The warning lights have been activating on and off for about 20,000 miles. The system would always return to normal after I restarted the car. Has anyone had this problem? I don't want to get screwed by a dealer if there is a simple fix. Thanks.
 

·
Registered
Joined
·
10 Posts
Hi everyone,

I am new to this forum.

I have the same problem with my ABS/STD. The fault indication lights goes off after restart or after a short drive.

I took it to the local dealer for checking and they told me that it was due to ABS module losing contact with the sensors located at the wheel. I was advised to clean the sensors.

Would frequent ABS sensor contact disruption cause the ABS module to fail completely? A friend of mine has the same problem on his BMW but he has been living with the on/off problem for the last 3 years without any preventative maintenance on the ABS sensor/module. Please advise.

Thank you
 

·
Volvo Guru !
Joined
·
5,908 Posts
Is should not cause it to go bad completely.It will just set a code for that sensor when it happens.
 

·
Registered
Joined
·
1 Posts
I sent my ABS module to Victor. He said he repaired it. I drove the car while the ABS unit was being repaired. When I put the ABS unit back in the ABS light and the STC message went out but the car will not run. It will start, run for a second or two then die. Any suggestions?
 

·
Registered
Joined
·
162 Posts
Your ABS module may require a software reload so the car knows that the module is back in the car. I also don't know who this victor fella is but if he rebuilt the module incorrectly than the module might not be communicating on the vehicles network. So the ECM may not be able to relay messages to the CEM.
 
1 - 6 of 6 Posts
Top