Volvo Owners Forum banner
1 - 4 of 4 Posts

·
Registered
1994 Volvo 850 SE 2.4 V10
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,

Problem started with "lambda" light on, and lots of engine stutter/rough running..
Error codes:
3-2-4​
Camshaft position sensor signal erratic

3-1-4​
Camshft position sensor signal missing or defective

First i thought Crank sensor replacement would fix it, yeah cable routing was and is ok. Cleared the codes and light disappeared, but still running on the rough side at idle and below 2000rpm.
Next i changed cam pos. sensor, but lo and behold lambda light back and cam sensor code+ engine runned like crap(before RPM sensor replacement). Replaced the old cam sensor back and again code/light gone??

Sparkplugs, distriputor cab and rotator are couple months old, sparkcables and coil unit are old but i tested every spark cable and spark is present.
Dont know anymore what to do next, maybe ill change spark cables and coil. Check sparkplugs are they ok..
 

·
Super Moderator
Joined
·
1,954 Posts
lambda light will be the o2 sensors in the exhaust, if one of these isnt reporting correctly the engine will run like cr*p
not sure if that model has a single o2 sensor or a pair, but its either going to be the sensor failed or the heater circuit for the sensor.
(2 pin o2 sensor- no heater circuit, 4 pin sensor heater circuit, check there is a supply to the o2 heater circuit.
 
  • Helpful
Reactions: karilo76

·
Registered
1994 Volvo 850 SE 2.4 V10
Joined
·
3 Posts
Discussion Starter · #3 ·
Thx Grendel for very valid point! Didn't believe or even consider it would be o2 since code was not present, alas come to think of it o2 is also major player in ignition scheme.

Plan D: Ill remove sensor and try to clean it+ purge ECU. It might be that o2 sensor data is messed up since i drove approx week(waiting for parts) with faulty RPM sensor(joy ride).
 

·
Registered
1994 Volvo 850 SE 2.4 V10
Joined
·
3 Posts
Discussion Starter · #4 ·
Wood Gas Metal Auto part Household hardware


Well i did get o2 sensor out relatively easy, cleaned with crc carb cleaner spray and reinstalled it. Lambda light on immediately on start and A2 521 code for o2 sensor heating. Looks like i am next replacing o2 sensor.. Engine runs slightly better, but still rough on low rpm.
 
1 - 4 of 4 Posts
Top