Volvo Owners Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there

Looking for some advice on a couple of issues I have with my 240.
The car is a '93 torslanda with 160,000 on the clock.

Firstly the fuel gauge doesn't work.
It used to, then it sometimes did, now it won't move at all.
I'm thinking that I need to get in behind the dashboard and replace a fuse...

Secondly there is an intermittant idle problem.
Every now and again whilst in neutral the revs drop off and the engine stalls.
Doesn't happen often, but when it does it persists for a while, usually till it gets turned off and left for a bit. I've also noticed some pulling from the engine during motorway driving which may be related. It's a pretty rare event, but somethimes (whilst on the motorway) the engine drops all power then kicks in again, giving a lurching/pulling motion.
I'm thinking it might be something to do with my injectors...

And, while I have your attention, the llamada light on my dash has just lit.
I reckon it's my cat, but if anyone can confirm that then I'll resign myself to the large bill that will accompany it.

These issues aren't stopping me getting about, but any help or advice would be gratefully apreciated.

cheers
Doug
 

·
Volvo Guru !
Joined
·
5,908 Posts
The sending unit in the tank might be bad for the guage.

Try cleaning the throttle body.

The O2 sensor might be bad will also cause the running problems.
 

·
Registered
Joined
·
9 Posts
There is a voltage regulator on the instrument panel that send 5v to the fuel tank sending unit and the temp guage, I had a lot of erratic fuel and temp readings till I replaced it. It looks like a big circuit breaker with 3) 1/4" male slide connectors on it. Your lamda light could might be on due to a mileage meter. Look for a box connected to the speedometer cable it will have button you can push in with a pen or something pointy. You should check your EGR valve for carbon deposits though, this can lead to rough running.
 
1 - 4 of 4 Posts
Top