Volvo Owners Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I have a 2000 (New Shape) V70 2.4 (140bhp). I have just bought the car. I am having a few problems with it starting first thing in a morning. It is fine starting during the rest of the day.
It will start on first try of the ignition. The engine revs will rise to about 1200 - 1500 but then after about 5 seconds the revs drop to 500 - 750 and the engine splutters!. Pushing the accelerator pedal doesn't increase the revs.
The engine will either then cut out or after about another 5 seconds it will return to normal idling and will be fine for the rest of the journey.

Any suggestions as to what might be causing this?

Thanks
 

·
Premium Member
Joined
·
8,352 Posts
Try cleaning the idle air controller valve (if applicable).
 

·
Premium Member
Joined
·
8,352 Posts
If the two still don't work, check the MAF sensor.

If still no joy, please tell us, and we'll see what else...
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
I have just had the car serviced and I was still having the starting problem. I have celaned all the throttle body out today and the MAF sensor. I used the typical intake spray cleaners.

The car is now running very rough. It will start, but then idles very rough. If you touch the accelerator only slightly then the revs will shoot right up to maybe 3000 rpm. Even when you take your foot off the accelerator they dont immediately drop back down again. They slowly over time come back down to a rough idle.

Any suggestions, do you think the throttle body might have finally given up. Note the car has done 247,000 miles!
 
1 - 5 of 5 Posts
Top