Volvo Owners Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
The car has plenty of freon and no leaks. I put in a new climat control panel. Relay tested good. At this point there's no signal to the relay from the ecm. Is there a way to test the ecm or where do I go from here?
 

·
Volvo Guru !
Joined
·
5,908 Posts
What about the high pressure switch?

If you have power to the low pressure switch is should work.The low pressure switch is on the end of the circuit.What about the sensor on the compressor?

If you have power at the low pressure switch then you should have power at the compressor.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Ok, checked the high pressure switch and it's getting power. What sensor are you talking about on the compressor?
 

·
Volvo Guru !
Joined
·
5,908 Posts
There is a sensor that screws into the back of the compressor.Follow the wire for the compressor.Then you should find it you can elliminate the sensor and plug straight to the compressor.

Do you have power at the compressor?
 

·
Registered
Joined
·
11 Posts
No i'm not getting any power to the compressor because the relay isn't getting any power to itself. It's not getting power from the ecm to the relay, but the relay isn't getting activated. There is power to the compressor side of the relay. I'll go check the sensor.
 

·
Volvo Guru !
Joined
·
5,908 Posts
But the way the circuit works if you have power at the low pressure switch then you should have power at the compressor.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
Ok, did some more checking and turns out i'm not getting power to the low pressure switch. Where does this thing get it's power from? I read in the wiring diagram that it gets it's power from the control panel on the dash. is this correct?
 

·
Volvo Guru !
Joined
·
5,908 Posts
Yes that is correct.

Jump the connection at the switch.Then trace for power.
 
1 - 11 of 11 Posts
Top