Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 95 850 No Communication To Srs
rred
post Jan 27 2021, 12:50 PM
Post #1


Newbie


Group: Members
Posts: 14
Joined: 3-June 09
Member No.: 57,722
Status: Offline
Location: USA, Lansing, MI
Drives: 1995 volvo 850



Hello,

This is for my 95 Volvo 850 sedan base. It failed the state safety inspection because the SRS light does NOT turn on when starting the car and the OBDII reader shows no communication to SRS system. (This car has both the jump box under the hood and the OBEII connector below the coin holder.) The mechanic shop where I get the inspection done does not work on Volvo, so I went to another shop for European cars. The mechanic told me he can't read anything out for the SRS with his computer and suggested me to sending the car to the dealer.

Before I went to the second shop, I had used the jump box under the hood to read the codes. It reports some and error codes and I removed them. Then it reports the normal 1-1-1. However, this doesn't fix the problem.

Except for letting the dealer work on it, is there anything I can do by myself? If I replace the SRS module by a used one, will it fix the problem? Is there an instruction about how to replace it?

This car is old but still runs well. I've owned it for more than 10 years and it never gave me a big issue. I just put on two new tires and replaced the upper engine mount bushing by myself. It will be a pity for me to give it up for this problem. Many thanks for any suggestions.
Go to the top of the page
 
QuoteReply
grendel1960
post Jan 27 2021, 01:59 PM
Post #2


Veteran
Group Icon

Group: Super Mod
Posts: 1,839
Joined: 25-June 06
Member No.: 16,314
Status: Offline
Location: Canterbury UK
Drives: 2002 Volvo V70 D5 S



i may be wrong but I thought the obd connection on the early models that also has the jumper box just reads the engine codes not the srs codes, this is a very early version of obd, and i am pretty certain i never could use the obd connector for anything other than engine codes on mine.
Go to the top of the page
 
QuoteReply
grendel1960
post Jan 27 2021, 02:11 PM
Post #3


Veteran
Group Icon

Group: Super Mod
Posts: 1,839
Joined: 25-June 06
Member No.: 16,314
Status: Offline
Location: Canterbury UK
Drives: 2002 Volvo V70 D5 S



1995 was the changeover year, as indicated by the fact that you have both OBD types fitted, codes can be found here
https://www.matthewsvolvosite.com/volvo-dia...s-1995-to-1998/ but this does say that some OBD11 plugs were not fully wired in to all of the diagnostics, so it may be that your obd11 was never connected to the srs, if you can get codes on the odb1 jumper box for the srs that should suffice, its probably just ignorance of the changeover for that year on the part of the test station.
it tells you here that 1995 was the changeover year
https://www.matthewsvolvosite.com/read-codes-volvo-850/
Go to the top of the page
 
QuoteReply
grendel1960
post Jan 27 2021, 02:15 PM
Post #4


Veteran
Group Icon

Group: Super Mod
Posts: 1,839
Joined: 25-June 06
Member No.: 16,314
Status: Offline
Location: Canterbury UK
Drives: 2002 Volvo V70 D5 S



as far as the srs light goes, have you checked the fuses, or the bulb?
Go to the top of the page
 
QuoteReply
rred
post Jan 27 2021, 02:25 PM
Post #5


Newbie


Group: Members
Posts: 14
Joined: 3-June 09
Member No.: 57,722
Status: Offline
Location: USA, Lansing, MI
Drives: 1995 volvo 850



QUOTE (grendel1960 @ Jan 27 2021, 02:15 PM)
as far as the srs light goes, have you checked the fuses, or the bulb?


The fuse looks good. But I haven't checked the bulb. I've almost convinced the SRS module has problem because of no reading. But after reading the above posts, I think I'll start from checking the bulb.

Thanks a lot!
Go to the top of the page
 
QuoteReply
rred
post Jan 27 2021, 04:51 PM
Post #6


Newbie


Group: Members
Posts: 14
Joined: 3-June 09
Member No.: 57,722
Status: Offline
Location: USA, Lansing, MI
Drives: 1995 volvo 850



I removed the instrument cluster and I'm surprised to find there's NO BULB there! (picture: https://pasteboard.co/JLDt4We.jpg) Another thing I found is the clip of the instrument cluster has not been put on. That explains why it always shakes when the car's running. Not sure whether the SRS bulb is shaken off. I put the wind shield washer light to the SRS position and it works as expected. I think the problem is solved now. I just need to find a bulb with socket to put on.

(IMG:https://pasteboard.co/JLDt4We.jpg)

This post has been edited by rred: Jan 27 2021, 05:03 PM
Go to the top of the page
 
QuoteReply
grendel1960
post Jan 28 2021, 12:09 AM
Post #7


Veteran
Group Icon

Group: Super Mod
Posts: 1,839
Joined: 25-June 06
Member No.: 16,314
Status: Offline
Location: Canterbury UK
Drives: 2002 Volvo V70 D5 S



its always worth checking the cheap solutions before the expensive ones of replacing the bigger modules.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo 850 Forum Next Newest »
  Advanced Search

2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Noise At Acceleration
noise at shift, acceleration, deceleration
5 vbertone 9,537 28th January 2021 - 02:40 AM
Last post by: Auld_Finger
No New Posts Noisy Ac Compressor That Works
A/C
9 outofworkjoe 6,385 2nd September 2020 - 04:10 PM
Last post by: ishmot
No New Posts Tow Hitch Xc 90
0 fsDriver 6,433 21st July 2020 - 12:06 PM
Last post by: fsDriver
No New Posts Total Loss Of Electrical Power 2006 Xc70
0 CSjolund 4,659 10th July 2020 - 09:39 PM
Last post by: CSjolund
No New Posts Topic has attachmentsNo Mount For Slave Cylinder
0 ddininio 26,780 9th April 2020 - 06:45 PM
Last post by: ddininio

 
> Link To Us
If you found our site useful please link to us <a href="https://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 27th February 2021 - 06:59 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.