Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Media System Not Working, Media system not working
Newvolvoowner1
post Jun 10 2019, 11:39 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 10-June 19
Member No.: 247,021
Status: Offline
Location: Hull, UK
Drives: Volvo C30 1.6 petrol 2010



After some time of my stereo / Media system not working, my car was in the garage for its MOT today and I asked them to look at the issue with my stereo. Back in Feb my battery died and someone came to help and put the leads on their battery the wrong way round. He fried my battery and alternator (they were literally smoking) and my stereo hasn’t worked properly since. Obvs the battery and alternator now fixed. And yes, i’ve waited until now for the stereo to be looked at. The garage have checked the fuses, they don’t think that’s the issue, but did say the inner unit is very hot. He recommended getting a new unit. Does anyone think this will be a problem or is possible? Is it an easy fix? I can look for a second hand one with the stereo code etc, but is that enough?
Thanks
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo C30 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Not Starting After Heavy Rain
0 cooltony91 1,773 1st July 2015 - 09:14 PM
Last post by: cooltony91
No New Posts Not Starting After Heavy Rain
0 cooltony91 1,587 1st July 2015 - 08:09 PM
Last post by: cooltony91
No New Posts Not Start Without Any Messages.
0 Kikyoung 2,256 20th April 2014 - 02:36 AM
Last post by: Kikyoung
No New Posts Topic has attachmentsNot All Oil Filters Are Created Equal
Cut Open Filter for a 850
8 SeaMike 3,628 20th January 2014 - 11:31 PM
Last post by: Kiss4aFrog
No New Posts Note On Brake Hoses, Power Steering Hoses
0 PersonFromPorlock 1,254 27th June 2013 - 06:27 PM
Last post by: PersonFromPorlock

 
> Link To Us
If you found our site useful please link to us <a href="https://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 10th August 2020 - 10:07 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.