Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Electrical Probs Part 2/ Any Help, Tech?, Battery Discharge
post Jul 31 2005, 02:24 AM
Post #1


Newbie


Group: Members
Posts: 14
Joined: 30-January 05
Member No.: 2,778
Status: Offline



Greetings again,
My little 122 had generator and voltage regulator replaced in January '05 (before I bought it), and since I have had it, has had battery discharging, and not re-charging. On the 18th, we jumped and had mechanic test-- battery good, but problems with the charging system. He checked connections, found some corrosion, cleaned, and we seemed to be good. Car sat for a week-- fired right up tonight--and then, as we drove it, the lights got dimmer, and it appeared charge was diminishing, and it would start imtermitently. Can it be faulty parts-- or connections..or what do you think?

I will take it back down on Monday...but would like to be armed with some knowledge..
Melinda
Go to the top of the page
 
QuoteReply
The Doctor
post Jul 31 2005, 02:58 AM
Post #2


Expert
****

Group: Members
Posts: 773
Joined: 2-May 05
Member No.: 4,718
Status: Offline
Location: Wonga Beach, Qld, Australia
Drives: Volvo 1976 264



If car has no ampmeter [old cars used to have em] it would be worth getting one installed - then no more guessing what the whole lot [alternator battery and reg] are doing
Go to the top of the page
 
QuoteReply
Tech
post Jul 31 2005, 08:13 AM
Post #3


Volvo Guru !
***

Group: Members
Posts: 5,908
Joined: 5-November 04
Member No.: 1,295
Status: Offline
Location: Fl.
Drives: Mustang,1995 Yellow T5-R,1996 850 Trubo



I would double check the wiring.If all is good the the alternator is most likely bad.
Go to the top of the page
 
QuoteReply
post Jul 31 2005, 10:15 AM
Post #4


Newbie


Group: Members
Posts: 14
Joined: 30-January 05
Member No.: 2,778
Status: Offline



I will ask about that. Good idea.
Thx.
Go to the top of the page
 
QuoteReply
post Jul 31 2005, 10:18 AM
Post #5


Newbie


Group: Members
Posts: 14
Joined: 30-January 05
Member No.: 2,778
Status: Offline



Thanks, Tech, too.

That was my plan. II think we may need to send the part back to the mechanic who installed it-- seems it should last longet than 7 months...I would expect a free replacement. Alternator is the same as generator, correct?
md
Go to the top of the page
 
QuoteReply
Tech
post Jul 31 2005, 01:14 PM
Post #6


Volvo Guru !
***

Group: Members
Posts: 5,908
Joined: 5-November 04
Member No.: 1,295
Status: Offline
Location: Fl.
Drives: Mustang,1995 Yellow T5-R,1996 850 Trubo



Yes it is the same.
Go to the top of the page
 
QuoteReply
post Aug 10 2005, 10:02 AM
Post #7


Newbie


Group: Members
Posts: 14
Joined: 30-January 05
Member No.: 2,778
Status: Offline



Tech-- You were right--the Generator is bad (only outputting 8 amps..) we are now in the process of seeing if the warranty will he available (or another generator available...)
MDutton :liebe011:
Go to the top of the page
 
QuoteReply
Tech
post Aug 10 2005, 10:31 PM
Post #8


Volvo Guru !
***

Group: Members
Posts: 5,908
Joined: 5-November 04
Member No.: 1,295
Status: Offline
Location: Fl.
Drives: Mustang,1995 Yellow T5-R,1996 850 Trubo



Keep me posted.
Go to the top of the page
 
QuoteReply
post Sep 9 2005, 09:26 PM
Post #9


Newbie


Group: Members
Posts: 1
Joined: 9-September 05
Member No.: 7,599
Status: Offline



Hi, I have a similar problem with my 67 122 S, except when it gets warm some times it won't start but if I jump across the solenoid on top of the starter with a screw driver it starts and sometimes it doesn't. The switch seems to be making, the battery charges from alt when running, around 13 VDC. Is there a relay in the circuit somewhere? Or could it be the voltage regulater. And if it is should I change the Alt with the Regulater? This seems to only occur when the car is warm and causes me to get stuck out from time to time. Any help will be appreciated. Thanks!!

Steve
Go to the top of the page
 
QuoteReply
Tech
post Sep 10 2005, 11:02 AM
Post #10


Volvo Guru !
***

Group: Members
Posts: 5,908
Joined: 5-November 04
Member No.: 1,295
Status: Offline
Location: Fl.
Drives: Mustang,1995 Yellow T5-R,1996 850 Trubo



Sounds like the starter itself might be bad.
Go to the top of the page
 
QuoteReply
« Next Oldest Other Volvo Models Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachmentsHelp: Manual Shifter Binding When Moving Into Neutral
shifer problems
11 GP-s40-t5 6,830 1st July 2020 - 10:12 PM
Last post by: GP-s40-t5
No New Posts Parts From China?
0 Acholla 1,570 15th January 2020 - 04:59 AM
Last post by: Acholla
No New Posts Help! Snow Chains For New Xc90
XC90
0 Astro_boy 1,112 31st December 2019 - 06:42 PM
Last post by: Astro_boy
No New Posts Help With Volvo 240 Ignition Troubleshooting Flow Chart?
0 123tim 1,072 20th November 2019 - 02:30 PM
Last post by: 123tim
No New Posts Anyone Else Screwed Over By John Parker?
2 deadken 10,060 3rd November 2019 - 06:46 PM
Last post by: notThatShane

 
> Link To Us
If you found our site useful please link to us <a href="https://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 15th August 2020 - 03:41 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.