Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Ignition Problem?, Key turns but car won't start!
Stevieg
post Mar 6 2006, 08:30 AM
Post #1


Newbie


Group: Members
Posts: 2
Joined: 6-March 06
Member No.: 12,597
Status: Offline
Location: USA
Drives: 1998 Volvo S90



Hi- I am at my wits end. My mechanic has had my car three times, 4 days at a time and can't find the problem. Here is what happens to my 1998 Volvo S90:


I put the key in the ignition and the car pre-start lights come on but the car wont turn over. Had the battery checked, no problems there. Had the battery cables changed, still no problem there. Had a new starter put in and still the same thing happens.

When I had the car towed to the mechanic, it started fine. Two days later the car died again. Sent it to the mechanic and when he got it, it started fine. On the third time I had it towed to him It didn't start. He diagnosed the problem as a relay switch. I got the car back yesterday and same problem...turn the key and nothing. Out of anger I had the wife sit in the car while I pushed the car to a nearyby shopping plaza. As soon as we put the car in a spot, it started right up!! Is this an ignition switch gone bad? A fuse? I can't figure why the car would start when it changes positions. PS- I put the car in neutral and park numerous times in an attempt to start it, with no luck. Anybody have an idea?
Go to the top of the page
 
QuoteReply
Auckland
post Mar 6 2006, 09:08 AM
Post #2


Veteran
Group Icon

Group: Super Mod
Posts: 1,718
Joined: 12-January 05
Member No.: 2,310
Status: Offline
Location: New Zealand
Drives: 1999 S80



:cat: Hi there Stevieg. :00000732: to Volvo forums.

:liebe011: for joining us.

Hopefully some of the experts shall reply to you soon.

Please keep us posted with your progress/experiences.

Cheers :right:
Go to the top of the page
 
QuoteReply
starfish
post Mar 11 2006, 10:38 PM
Post #3


Full Member
**

Group: Members
Posts: 102
Joined: 14-December 05
Member No.: 9,824
Status: Offline
Location: USA
Drives: 2001 Volvo V70XC



The first thing I would do is find a new mechanic! LOL! Unfortunately it seems alot of money was thrown into unnecessary repairs already. Perhaps you need a more experienced Volvo tech or bring it into the dealer for servicing. Your PNP switch might be failing and preventing the car from starting.
Go to the top of the page
 
QuoteReply
Tech
post Mar 11 2006, 10:53 PM
Post #4


Volvo Guru !
Group Icon

Group: Super Mod
Posts: 5,908
Joined: 5-November 04
Member No.: 1,295
Status: Offline
Location: Fl.
Drives: Mustang,1995 Yellow T5-R,1996 850 Trubo



My Vote is for the PNP as well.
Go to the top of the page
 
QuoteReply
Bruce1966
post Apr 8 2006, 05:20 PM
Post #5


Newbie


Group: Members
Posts: 6
Joined: 1-April 06
Member No.: 13,498
Status: Offline
Location: Southampton UK
Drives: 1998 Volvo S80



Hi. My S80 seems to have the same intermittent fault. Did you manage to find a cure?
Go to the top of the page
 
QuoteReply
Stevieg
post Apr 8 2006, 08:28 PM
Post #6


Newbie


Group: Members
Posts: 2
Joined: 6-March 06
Member No.: 12,597
Status: Offline
Location: USA
Drives: 1998 Volvo S90



We had the starter replaced twice and a relay switch replaced twice. So far, it seems to be working. Good luck
Go to the top of the page
 
QuoteReply
j3cubcapt
post May 30 2006, 08:46 PM
Post #7


Newbie


Group: Members
Posts: 4
Joined: 3-November 04
Member No.: 1,276
Status: Offline
Location: Dallas Texas
Drives: 1998 S90



98 S90, same thing is going on with me.....

Car ran fine, stopped at the store, shut down, got back in, turned the Key and Nothing....

Well "Nothing" is the prestart lights were on, I turned the key and all of the lights went dim. Waited a few seconds and the lights came back bright. There is a click of the starter seloniod but then nothing. Tried to Jumpstart and got the same results.

Had the car towed to the house, removed the starter, took it to AutoZone "MISTAKE #1" they tested it and found it bad OF COURSE! Bought new one, installed it and the same thing is going on.

I can turn the engine over, so no siezed engine. The battery is reading 12.77Vdc.

Where and What is the "Relay Switch" refered to in the other posts.

Where and how do I test the Relay and/or the PNP switches.

Could my Ignition switch cause these problems? Im WAS having some small difficulty with it not fully springing back to the "Run" position after start which made me manually return it to that position to move the gear shift out of PARK.

Thanks for the HELP!!!!!

Will
Dallas Texas
Go to the top of the page
 
QuoteReply
pistio
post Aug 30 2009, 11:41 AM
Post #8


Newbie


Group: Members
Posts: 10
Joined: 12-May 09
Member No.: 56,786
Status: Offline
Location: San Diego, California
Drives: 1989 760 Volvo Turbo Intercooler



I have the same problem with my 89 760 turbo.........its the one and only IGNITION MODULE! Tell your mechanic to check that out! usually the ignition module decides to overheat and turn the engine off whenever it wants to...a quick fix, would be tapping the ignition module with the back of a screwdriver, BUT DONT GET SO OVERCONFIDENT AND RELIANT ON THIS TRICK! just do it to get to the mechanic or to a safe place to park...even putting an icepack on the module itself should work......yes sir! it took me sooo many unnecessary repairs to find this out! I hope this helps...... (IMG:style_emoticons/default/thumbsup.gif)
Go to the top of the page
 
QuoteReply
tam85
post Apr 8 2010, 09:50 PM
Post #9


Member
*

Group: Members
Posts: 28
Joined: 8-April 10
Member No.: 71,243
Status: Offline
Location: illinois
Drives: 2000 volvo



to fix a no-start problem you need to test a lot of things. check your fuses, battery and ignition switch. one of the most common issue why the car wont start is a dead battery. just check your battery and clean all the connections. if the starter still silent, it maybe a faulty ignition switch. maybe the switch need replacement. (IMG:style_emoticons/default/liebe011.gif)
Go to the top of the page
 
QuoteReply
danielm85948
post Jul 4 2010, 05:46 AM
Post #10


Senior Veteran
***

Group: Members
Posts: 2,810
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (Auckland @ Mar 6 2006, 09:08 AM)
(IMG:style_emoticons/default/cat.gif) Hi there Stevieg. (IMG:style_emoticons/default/00000732.gif) to Volvo forums.

(IMG:style_emoticons/default/liebe011.gif) for joining us.

Hopefully some of the experts shall reply to you soon.

Please keep us posted with your progress/experiences.

Cheers (IMG:style_emoticons/default/right.gif)

get a new part of the electrical part of the ignition switch held on by two crosshead screws,look on the post i did for the same thing,on how to change this switch ,the back of the ignition switch,has the electrical part of it.go on the internet for a new switch,try some oil in the ignition switch first,like wd 40.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo S90 & V90 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachmentsProblems With Dashboard Air Ducts
One has a fin loose and the other has foam and a yellow-white thing
0 qwertie64982 16 28th August 2014 - 05:07 PM
Last post by: qwertie64982
No New Posts Ignition Won't Turn Past 1st Postition
5 EagleBarra 466 11th March 2014 - 08:53 PM
Last post by: Deeks
No New Posts Problem With Having Low Battery Power?
2 ImortalZomby 743 29th July 2013 - 04:32 AM
Last post by: SykO
No New Posts Ignition Noise
Odd noise when ignition button is pushed
1 XC60 Italy 529 7th June 2013 - 02:27 PM
Last post by: zhann
No New Posts Problem With Interior Light In "new" Volvo
2 JensDK 407 2nd June 2013 - 02:53 AM
Last post by: JensDK

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 1st September 2014 - 04:04 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement