Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> P0015 Error Code After Cold Start
tors40
post Apr 8 2013, 12:10 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 3-April 13
Member No.: 115,174
Status: Offline
Location: Canada
Drives: s40, 2004, 1.9l turbo



I have S40 2004, ~84000 km. Engine light tuned on, scanner showed a pair of P0015s, one pending. I decided to monitor with a scanner what is happening and found out that error code appears during engine cold start, after the car was parked for 5-6 hours or overnight. At first one error code appears as pending and after another cold start engine light comes up and I can see 2 of them. The same thing happens if I turn cold engine on and off two times in a row, but if I turn the cold engine on, let it run idle for 2 min, turn it off and on again, there is only one pending code sitting their.

I desided to test the car for a long drive in a mixed city/highway cycle. Cleaned the codes before that. Was driving for about 2.5 hours, with some stops, no error codes showed up. Then parked the car for couple of hours. After that start of the engine was clean.
I haven't noticed any changes in car performance, fuel consumption or overheating.

I did engine flush with Seafoam (used half of 473 ml can for 200 km), changed oil and filter after, put synthetic 5W30. Mechanic told me the filter was very dirty. He also checked CVVT solenoid, said it was a bit dirty. He cleaned it without taking apart. It clicks when power is applied. Still mechanic said he is not 100% sure that it working properly.
Anyway, nothing of that helped to get rid of error codes showing up.
I read some postings regarding P0015 and I am not sure what to do.
Any help is higly appreciated.
Go to the top of the page
 
QuoteReply
pmondrian
post Aug 21 2016, 10:06 PM
Post #2


Newbie


Group: Members
Posts: 1
Joined: 29-March 15
Member No.: 140,066
Status: Offline
Location: New Jersey
Drives: 2001 S40



Did you ever find a fix to your P0015 problem?
Go to the top of the page
 
QuoteReply
« Next Oldest 1G (1995-2004) S40 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Start Stop Not Working (noisy)
0 trickyg 118 29th October 2016 - 01:10 PM
Last post by: trickyg
No New Posts Code P0740 Torque Converter Clutch Solenoid Circuit
Most likely fix
1 rickeross76 4,263 24th July 2016 - 08:01 PM
Last post by: scottydoes
No New Posts Aftermarket Spring Seat/strut Mount Blown After 8 Months
2 LiteWait 216 8th July 2016 - 02:00 PM
Last post by: LiteWait
No New Posts Aftermarket Satnav-multimedia Unit
0 LPM 230 20th June 2016 - 01:10 PM
Last post by: LPM
No New Posts Cold Start Injector Or Check Valve
240 GL 1982
7 wild1 1,250 11th January 2016 - 08:27 AM
Last post by: Greg Fielder

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 26th February 2017 - 09:37 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
 
Privacy Statement