Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 89' 240 Dl Won't Start
michael22
post Jan 13 2012, 12:27 PM
Post #1


Newbie


Group: Members
Posts: 7
Joined: 22-October 11
Member No.: 97,220
Status: Offline
Location: South Carolina
Drives: 89 240-DL



Am the proud owner of a 240 DL 89 Volvo.
Lately however she's been having problems.
This is how it started. Every once in a while if I'm driving seems I'm not getting fuel to the engine. Just temporarily. It seems to do this only when it's warm out. Occasionally it has even stalled. Then i have to let it cool and start it back up. Three days ago it did it again. This time however it wouldn't start back up. I checked the ignition coil and cables (all of them) seems fine. Check the main fuel pump relay under the glove box, also fine. Alternator and starter also fine. It does want to crank. It doesn't seem to get fuel to the engine. Am left with just the main fuel pump. However before i replace that does anyone have an idea what else it could be? I keep thinking there's another relay I missing as the shut off was almost instantaneously. No sputtering. Heard of a cooling fan relay, which supposedly has something to do with ignition (not sure where it is).
I have also recently replaced Air mass meter and Crank position sensor.
Any help would be greatly appreciated as i know of no mechanic in the area I trust 100%.
thanks
Kimberlie
Go to the top of the page
 
QuoteReply
danielm85948
post Jan 13 2012, 08:58 PM
Post #2


Senior Veteran
***

Group: Members
Posts: 2,818
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (michael22 @ Jan 13 2012, 12:27 PM)
Am the proud owner of a 240 DL 89 Volvo.
Lately however she's been having problems.
This is how it started. Every once in a while if I'm driving seems I'm not getting fuel to the engine. Just temporarily. It seems to do this only when it's warm out. Occasionally it has even stalled. Then i have to let it cool and start it back up. Three days ago it did it again. This time however it wouldn't start back up. I checked the ignition coil and cables (all of them) seems fine. Check the main fuel pump relay under the glove box, also fine. Alternator and starter also fine. It does want to crank. It doesn't seem to get fuel to the engine. Am left with just the main fuel pump. However before i replace that does anyone have an idea what else it could be? I keep thinking there's another relay I missing as the shut off was almost instantaneously. No sputtering. Heard of a cooling fan relay, which supposedly has something to do with ignition (not sure where it is).
I have also recently replaced Air mass meter and Crank position sensor.
Any help would be greatly appreciated as i know of no mechanic in the area I trust 100%.
thanks
Kimberlie

check for broken wires,check all fuses,clean them or replace,it can be a dirty fuel filter,dirty spark plugs,ignition control module failing that is in the side wall of the engine bay,what did you do to check the fuel pump relay.
Go to the top of the page
 
QuoteReply
michael22
post Jan 14 2012, 08:45 PM
Post #3


Newbie


Group: Members
Posts: 7
Joined: 22-October 11
Member No.: 97,220
Status: Offline
Location: South Carolina
Drives: 89 240-DL



QUOTE (danielm85948 @ Jan 13 2012, 08:58 PM)
check for broken wires,check all fuses,clean them or replace,it can be a dirty fuel filter,dirty spark plugs,ignition control module failing that is in the side wall of the engine bay,what did you do to check the fuel pump relay.

did all you suggested. Except for for control module. will check that.
i heard relay clicking when i turned the key. Assume that means it's working
hanks for getting back.
kim
Go to the top of the page
 
QuoteReply
danielm85948
post Jan 14 2012, 11:22 PM
Post #4


Senior Veteran
***

Group: Members
Posts: 2,818
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (michael22 @ Jan 14 2012, 09:45 PM)
did all you suggested. Except for for control module. will check that.
i heard relay clicking when i turned the key. Assume that means it's working
hanks for getting back.
kim

when a fuel pump relay fails,it will still click,you can pull it apart with care,look for damage to the solder,it can have cracks in it,resolder it,google how to do this.
Go to the top of the page
 
QuoteReply
Matt Hamilton
post Jan 27 2012, 11:05 PM
Post #5


Newbie


Group: Members
Posts: 10
Joined: 27-January 12
Member No.: 103,173
Status: Offline
Location: Washington
Drives: 86' 240DL



And there are actually 2 relays inside of the fuel system relay. One might be stuck open while the other makes contact. Couple of butter knives and you can pop the cover off of it and inspect it more carefully.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo 240, 242, 244 & 245 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachments240 Wagon Just Purchased - Wheel Upgrade?
New Member Intro
3 wiffies 912 9th March 2014 - 01:39 PM
Last post by: vlvwagon
No New Posts 240 Wagon Cargo Cover
15 deadfan50 5,348 30th December 2013 - 05:54 PM
Last post by: vlvwagon
No New Posts Topic has attachments240 Fuel Pump / Economy Issue
8 langmead 872 8th December 2013 - 05:02 PM
Last post by: NorcalBrick
No New Posts Start Prevented
Start fails on first attempt w/txt messg
14 cnomann 16,860 30th November 2013 - 01:39 PM
Last post by: luapo
No New Posts Start Prevented Try Again - Help
v70
5 flowerpower31000 8,296 30th November 2013 - 01:18 PM
Last post by: luapo

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 20th October 2014 - 05:46 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement