Welcome Guest ( Log In | Register )

Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2004 Xc90 T6 Awd: Ecu(?) Problem
post Mar 27 2011, 03:47 AM
Post #1


Group: Members
Posts: 3
Joined: 27-March 11
Member No.: 87,359
Status: Offline
Location: Australia
Drives: 2004 Volvo XC90 T6 AWD

I just bought a 2004 XC90 T6 second hand with approx 100,000km on the clock. A couple of weeks ago, I noticed the yellow engine warning light had appeared and the engine was running a little roughly. I took the car to the dealer's mechanic as it's luckily still under warranty.

The mechanic indicated that it was a simple matter of replacing the injector coil(s) per the ECU. Over the next week before I could put the car in to be serviced the problems got worse: lack of power under full throttle, rough, coarse running, surging under light acceleration. The mechanic has replaced the injector coils, and the ECU indicates everything is in perfect condition. The car is also mechanically sound, however the problem persists. Has anyone experienced this problem, and if so, what did you do to rectify? Thanks!
Go to the top of the page
« Next Oldest Volvo XC90 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.


> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Xc90 T6 Awd
First timer
3 Sebnem 217 10th November 2015 - 10:16 AM
Last post by: illiquent
No New Posts Xc90 Trailering
Factory Trailer Packages
0 08GeezerGlide 103 1st November 2015 - 02:19 PM
Last post by: 08GeezerGlide
No new Xc90 Electrical/engine Power Failure
bizarre power failure
54 bradnight 45,864 28th October 2015 - 07:46 PM
Last post by: Esera
No New Posts Problems With Swm, Possibly?
No turn signal, no cruise control, no high beam.
8 murta 134 20th October 2015 - 02:16 AM
Last post by: murta
No New Posts 2004 Xc90
ABS Module
0 eriks805 52 8th October 2015 - 09:29 AM
Last post by: eriks805

> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
Time is now: 29th November 2015 - 06:03 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement