Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Engine System Service Required .. But No Codes!
V70 Driver
post Nov 17 2010, 12:22 PM
Post #1


Newbie


Group: Members
Posts: 7
Joined: 17-November 10
Member No.: 81,607
Status: Offline
Location: Brighton, UK
Drives: V70



Hi all,

Hoping someone can help....

We've recently had a service on our 2001 V70, oil, filters, plugs etc... and since then there's a message in the text bit of the dash saying "Engine System Service Required" and the cruise control has stopped working. There was also a "Service Required" light, but i got rid of that with the on/off press trip button thing.

There's no red or orange light on the dash and the message come's and goes... but the cruise control never works. (press the button but no CRUISE appears on the dash where it used to..

Now it get's weird....

I took it back to the garage (not a Volvo one) and they plugged in a computer and looked to find the error code .. but there isn't one they cleared the Error memory anyway and then tried car but Engine System Service Required .. Looked in memory, still no code..... they then looked in an other part of the car's memory (sorry for being vague!) and there was nothing there either.

Car off and back on ... no message ... car off and back on .. message ... and the CControl never works.

Their answer now is that there's nothing in the service that could have caused the problem and the say i need to take it to a Volve Garage - spending more money!!

Must add again, cos all the advice seems to centre around this ... there's no "Engine service" light on the dash. just the message....

Thanks for reading ... will be interested to see what the experts here make of it!!!

Cheers

James
Go to the top of the page
 
QuoteReply
V70 Driver
post Nov 29 2010, 06:24 AM
Post #2


Newbie


Group: Members
Posts: 7
Joined: 17-November 10
Member No.: 81,607
Status: Offline
Location: Brighton, UK
Drives: V70



Seriously? ... No replies at all?

Oh Dear!!
Go to the top of the page
 
QuoteReply
Peelot
post Dec 3 2010, 04:58 PM
Post #3


Full Member
**

Group: Members
Posts: 101
Joined: 3-December 10
Member No.: 82,376
Status: Offline
Location: Russia
Drives: 2006 Volvo XC 70



Hello, James
I think you need to go to official dealer Volvo, however if you don't want to spend your money you can to try disconnect a battery for 10-15 minutes and then to connect again. After it either the "Service Required" light will switched off (but it may be switched on after some time if your car really has any problems) or the garage computer will able to read diagnostic code. Good luck!
Go to the top of the page
 
QuoteReply
jda2000
post Dec 4 2010, 02:05 PM
Post #4


Member
*

Group: Members
Posts: 62
Joined: 12-January 10
Member No.: 67,428
Status: Offline
Location: USA
Drives: 2007 Volvo S60 2.5T



generic code readers are not picking up volvo proprietary codes.

You need the dealer for the correct diagnosis with their VIDA machine.
Go to the top of the page
 
QuoteReply
« Next Oldest 2G (2001-2007) V70, V70XC & XC70 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Nox Smog Failure 90 240
looking for culprits
3 carewoner 213 17th February 2014 - 12:12 PM
Last post by: carewoner
No New Posts Service Reminder Message
0 dr.andre 183 16th February 2014 - 04:08 AM
Last post by: dr.andre
No New Posts Topic has attachmentsNot All Oil Filters Are Created Equal
Cut Open Filter for a 850
8 SeaMike 486 20th January 2014 - 11:31 PM
Last post by: Kiss4aFrog
No New Posts Engine Immobilised !
Volvo Guard Alarm playing up.
4 slicknick 280 11th January 2014 - 09:41 AM
Last post by: TheGreekMason
No New Posts No Start Procedure This Will Apply To Any Car
procedure when your car does not start.
0 danielm85948 163 12th December 2013 - 11:33 AM
Last post by: danielm85948

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 20th April 2014 - 12:43 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement