Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2001 S40 Climate Control Unit, Blower Fan and CCU works intermittently
muirner
post Jun 21 2010, 09:08 PM
Post #1


Newbie


Group: Members
Posts: 2
Joined: 10-June 10
Member No.: 73,928
Status: Offline
Location: usa
Drives: 2001 volvo s40



My 2001 Volvo s40 1.9T has a climate control unit that works intermittently. When it quits working the lights and power to the CCU go off. If I press the rear defroster (sometimes sticky) or tap on the temperature dial, sometimes it will repower up briefly then go off again shortly later. I just replace the blower motor transistor, but the problem is less frequent, but is still continuing. Is this a problem with the CCU, or is there a loose power connector in the back of the CCU? Suggestions appreciated.
Go to the top of the page
 
QuoteReply
muirner
post Jun 26 2010, 07:24 PM
Post #2


Newbie


Group: Members
Posts: 2
Joined: 10-June 10
Member No.: 73,928
Status: Offline
Location: usa
Drives: 2001 volvo s40



Turna out the circuit board was loose inside the CCU. they use tie wraps to secure it down rather than replace the unit. sounds gerry rigged but at tleast the dealer knew that replacing the CCU was not a good solution cost wise.

QUOTE (muirner @ Jun 21 2010, 10:08 PM)
My 2001 Volvo s40 1.9T has a climate control unit that works intermittently. When it quits working the lights and power to the CCU go off. If I press the rear defroster (sometimes sticky) or tap on the temperature dial, sometimes it will repower up briefly then go off again shortly later. I just replace the blower motor transistor, but the problem is less frequent, but is still continuing. Is this a problem with the CCU, or is there a loose power connector in the back of the CCU? Suggestions appreciated.

Go to the top of the page
 
QuoteReply
Johnny B Good
post Oct 18 2010, 06:04 PM
Post #3


Newbie


Group: Members
Posts: 3
Joined: 17-October 10
Member No.: 80,144
Status: Offline
Location: Norwalk, CT
Drives: 2003 Volvo S40



i have the same problem, but the solution makes sense. i usually just smack mine and it starts working again. i will check it out and let you know if that fixes the problem
Go to the top of the page
 
QuoteReply
« Next Oldest 1G (1995-2004) S40 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Climate Control Ecu
Problems finding replacement
0 oaksbane 34 26th April 2015 - 07:16 AM
Last post by: oaksbane
No New Posts 2001 Volvo S40
Steering locked
1 Lesley 61 6th April 2015 - 11:08 AM
Last post by: grendel1960
No New Posts 2001 Volvo S80 Dont Start After Flat Battery
Help
2 Amareth 281 1st April 2015 - 06:54 AM
Last post by: andrewjohn1317
No New Posts 2001 S60
shift knob removal
0 wrightml 117 25th February 2015 - 01:23 PM
Last post by: wrightml
No New Posts 2001 S40 1.9d Hesitation
4 bangnmelo 521 26th December 2014 - 02:08 PM
Last post by: danielm85948

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 3rd May 2015 - 08:55 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement