Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 1991 940 Se Rough Start, Stalling
91940se
post Sep 22 2007, 02:37 PM
Post #1


Newbie


Group: Members
Posts: 4
Joined: 21-September 07
Member No.: 32,819
Status: Offline
Location: PA
Drives: 1991 Volvo 940 SE



Hi, my brick is getting harder to start, it always stalls immediately after a start, and sometimes stalls while braking even when it's warm. Any ideas where to start? 191K on her, FPR and in-tank pump on about 8-10K old.

I decided the clean the throttle body today. Bought some good throttle body cleaner and some paper gasket. While disconnecting the hose from the turbo to throttle body I noticed a huge hole in the bottom of the hose! I fixed it temporarily with some duct tape.

So, I continued, took the throttle body off and ewwww... It was really nasty looking inside! Cleaned it thoroughly with the cleaner and a toothbrush.

Put everything back together, thinking surely, one of these problems had to fix the stumbling issue. Before starting the car, I checked for codes, showed a 231, 232, and 212. Cleared the codes. Started it back up. Absolutely no difference at all!

Hmmm... did I hook everything back up correctly? NO! The throttle position sensor, that I had also cleaned the electrical connections on, was hanging down. I had forgotten to plug it back in.

Surely, that was now the problem. Plugged it in, cleared all the codes. Started the car, and again, absolutely no change!

Is the TPS bad? How can I check it?
Go to the top of the page
 
QuoteReply
deadken
post Sep 23 2007, 02:10 AM
Post #2


Senior
***

Group: Members
Posts: 291
Joined: 31-July 05
Member No.: 6,601
Status: Offline
Location: Long Island, NY
Drives: '83 240 (250+k), '91 940 Turbo, + '92 940 (R.I.P. '93 940)



The problem you described wouldn't be caused by a TPS. If the stalling happened every time you hit the gas pedal, then maybe. But, just plain stalling, not likely.

I'd take a good look at the Idle Control Motor. It is what lets the air bypass your throttle body when the throttle is closed (when you are not pushing on the gas pedal). It sits a bit below your throttle body and if you think your throttle body was gunked up, wait until you clean out this thing.....

Oh yeah.... To check the TPS, check the terminals with a continuity tester. Should be continous from the center to one outer when you are at idle and then from the center to the other outer when you reach about %90 throttle.
Go to the top of the page
 
QuoteReply
91940se
post Sep 28 2007, 08:26 PM
Post #3


Newbie


Group: Members
Posts: 4
Joined: 21-September 07
Member No.: 32,819
Status: Offline
Location: PA
Drives: 1991 Volvo 940 SE



Well, fixing, and then replacing the air intake hose stopped the decel stalling. But as I said, still had off idle hesitation, was gonna take the advice and clean the AIC next. But, the old brick just shut off and would not re-start on my wife the other day. So, when I got to the car, I looked at all the usual stuff, fuel pumps were running, I was gettin spark.. hmmm... so, I ran the Diagnostic Test Mode 3, really cool test by the way, everything sounded fine, except, no injector pulses...

So, since the cooling fan relay and radio suppression relay are identical, I swapped them. She fired right up! Drove it home, less than a mile so no need to worry about the auxiliary cooling fan.

Popped open the "bad" relay, looked at it under a magnifying glass, most of the solder joints were cracked! Fired up the old Weller heated up each joint to let the solder re-flow. Put the relay back in and the old brick fired right up, instantly! Not only that, NO MORE HESITATION! :beer:

So, moral of the story is... for an old brick that's slow to start, and has off idle hesitation, we need to put the radio suppression relay on the list. Best thing, no need to buy a new one, just re-solder the cracked joints.

Thank you!
Go to the top of the page
 
QuoteReply
deadken
post Sep 30 2007, 02:04 AM
Post #4


Senior
***

Group: Members
Posts: 291
Joined: 31-July 05
Member No.: 6,601
Status: Offline
Location: Long Island, NY
Drives: '83 240 (250+k), '91 940 Turbo, + '92 940 (R.I.P. '93 940)



Well, it is great to hear the you were able to fix the problem! I am sorry that your Wife had to get stuck (not too bad if she was only a mile from the house), but sometimes problems are easiest to diagnose when items go from so-so to fail.

Where is the radio suppression relay? Is it in the relay/fuse panel?
(IMG:http://www.swedishbricks.net/700900FAQ/relay.jpg) (IMG:http://www.swedishbricks.net/700900FAQ/relay3.jpg)

Or is that the one under the hood near the inner fenderwell (is it the right front on the non-turbo?) that sits right next to the cooling fan relay?

I would like to say 'Thank You' for posting back with your results/findings. The only way to really improve the responses/help we give people here is to know how they make out and what ultimately fixed their cars.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo 940 & 960 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts 940 Td Temp Needle Wont Rise
Advice requested what to check first
3 Conrad 192 16th April 2014 - 01:42 PM
Last post by: Conrad
No New Posts 1991 240 Rough Idle
Starts brilliantly but idle become rough once warm
11 froynglaven 596 9th March 2014 - 01:21 PM
Last post by: vlvwagon
No New Posts Service Reminder Message
0 dr.andre 186 16th February 2014 - 04:08 AM
Last post by: dr.andre
No New Posts 1991 940se Turbo No Power To Fuel Pumps
1 ninja85 187 14th January 2014 - 04:56 PM
Last post by: danielm85948
No New Posts Start Prevented
Start fails on first attempt w/txt messg
14 cnomann 14,305 30th November 2013 - 01:39 PM
Last post by: luapo

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 24th April 2014 - 05:12 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement