Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
6 Pages V   1 2 3 > »   
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Dashboard Problems, Dashboard Problems
darrendaly
post Feb 20 2007, 08:56 AM
Post #1


Newbie


Group: Members
Posts: 2
Joined: 20-February 07
Member No.: 24,906
Status: Offline
Location: Ireland
Drives: 2003 S60 D5



Hello all,

I'm new to the forum, but have had an S60 since 2001, 2.0 petrol first and then a 2003 D5.

I am having problems with my message centre and my indicator. The message centre won't display anything. It just a mass of jumbled letter moving about. The indicator lights and sound won't work on the dashboard although they are working fine outside.

The dealer say that a new dashboard is needed, which is very expensive.

Does anybody know if there is a fix to this? a reboot maybe?

Any help would be appreciated.
Go to the top of the page
 
QuoteReply
tennisnut
post Jun 17 2007, 11:07 AM
Post #2


Newbie


Group: Members
Posts: 1
Joined: 17-June 07
Member No.: 29,206
Status: Offline
Location: USa
Drives: 2003 s60



We are having the same problem with our 2003 S60. I read possible problem is wiring to the DIM? Did you get some resolution to your problem?
Go to the top of the page
 
QuoteReply
darrendaly
post Jun 18 2007, 03:35 AM
Post #3


Newbie


Group: Members
Posts: 2
Joined: 20-February 07
Member No.: 24,906
Status: Offline
Location: Ireland
Drives: 2003 S60 D5




No, the problem is still there. I've been advised that I will have to get a new dash as it is manufactured on a printed circuit board, which can't be fixed, apparently.

Regards,

Darren.
Go to the top of the page
 
QuoteReply
romkaromka
post Jul 3 2007, 07:46 AM
Post #4


Newbie


Group: Members
Posts: 14
Joined: 13-April 07
Member No.: 26,952
Status: Offline
Location: ESTONIA
Drives: 2003 Volvo S60 D5



Volvo does not repair these panels.
Really if you don't understand in electronics and nobody of your friends does not understand....only way to change panel in volvo center. it is about 2000$.

second way: if you understand in electronics...
1) ignition off
2) remove driver information panel
3) disconnect panel
4) dissassembly panel, remove all covers and remove indicators (speedometer, odometer, etc), simply remove all screws on the back side of panel and then pull slightly each indicator
5) there are electronic circuit board... the problem is usual in a voltage regulator or capacitor. Look at the capacitor, it is OK? no leakage?
there are also voltage regulator something like L4925N, you can try to replace this regulator + capacitor.

Go to the top of the page
 
QuoteReply
Seanzmac
post Jan 13 2008, 08:33 PM
Post #5


Member
*

Group: Members
Posts: 25
Joined: 11-January 08
Member No.: 36,856
Status: Offline
Location: Long Island
Drives: 2001 S-60 T5, Summer Ride 2002 Honda CBR 600F4I



I have a similar problem on my 01 S60 5T. My Info display is blank but everything else works fine. Could it be a fuse? If so which one? I can't find what they call it in the owners manual so I can't tell which fuse it is. Also what all does the display do/show, the owners manual says some stuff that scares the bejeese out of me, if one of these statements comes up I won't be able to read it and then my engine BLOWS I don't know what I would do. :crying: I will open it up next week and look for the blown Capacitor or regulator.
Go to the top of the page
 
QuoteReply
Seanzmac
post Jan 14 2008, 08:41 PM
Post #6


Member
*

Group: Members
Posts: 25
Joined: 11-January 08
Member No.: 36,856
Status: Offline
Location: Long Island
Drives: 2001 S-60 T5, Summer Ride 2002 Honda CBR 600F4I



Okay today I got brave, disconnected the battery, removed the DIM and then disassembled. SURPRISE, no blown cap or regulator just missing the ribbon cables that go between the board to the display!! :excl: The board looks like some of the LEDs have also been broken off!! What the HELL?!! I don't know who did it but It looks like someone purposely rigged the DIM to cover something up. I can't believe this!!! I pretty much know I am screwed but I just don't know how bad. Any lawyers out there? Can I go after the registered dealer on this or am I gonna just take this one in the shorts? BTW I don't think it really matters but everything else in the car works fine. I am sick just thinking about this.
Attached File(s)
Attached File  S60_010.jpg ( 266.5K ) Number of downloads: 1202
 
Go to the top of the page
 
QuoteReply
Seanzmac
post Feb 1 2008, 06:25 PM
Post #7


Member
*

Group: Members
Posts: 25
Joined: 11-January 08
Member No.: 36,856
Status: Offline
Location: Long Island
Drives: 2001 S-60 T5, Summer Ride 2002 Honda CBR 600F4I



Okay, i have read that volvo has to hook up the computer to install a new dash, but what if you put in a used one? If you were able to get a used dash and swap it out without going to volvo to program what, if anything wouldn't work? Would the speedo go crazy? Would the hidden Ejection seat launch you out of the car? :blush: Or would it just work but have the incorrect miles and work like the original. :liebe011:
Go to the top of the page
 
QuoteReply
raydar
post Feb 2 2008, 03:36 AM
Post #8


Senior
***

Group: Members
Posts: 198
Joined: 1-November 07
Member No.: 34,254
Status: Offline
Location: uk
Drives: 2007 s80 d5



Be carefull about swapping units as milage is kept in dash and CEM, the car will read the highest milage and use that. If you try your m8`s dash as a tester then put 20k on his car that would be all bad.

The dash would not work properly anyway, would need to be a dash that has been installed to your car by software.
Go to the top of the page
 
QuoteReply
Seanzmac
post Feb 2 2008, 09:13 AM
Post #9


Member
*

Group: Members
Posts: 25
Joined: 11-January 08
Member No.: 36,856
Status: Offline
Location: Long Island
Drives: 2001 S-60 T5, Summer Ride 2002 Honda CBR 600F4I



Okay I am not convinced. I bought a used DIM from ebay and Intend on trying it out. The miles on it is less than I have now so I am not worried about that. Is volvo trying to scam? Do they just tell people it has to be programmed so they can charge the exuberant prices for the part and install? Well I intend on finding out. I will let you know when I get it put in if I notice any foul effects. :beer:
Go to the top of the page
 
QuoteReply
TheGreekMason
post Feb 2 2008, 04:11 PM
Post #10


Expert Veteran
Group Icon

Group: Super Mod
Posts: 4,566
Joined: 9-August 07
Member No.: 31,123
Status: Offline
Location: Brooklyn, New York



what happened? did it work?
Go to the top of the page
 
QuoteReply
Seanzmac
post Feb 11 2008, 06:04 PM
Post #11


Member
*

Group: Members
Posts: 25
Joined: 11-January 08
Member No.: 36,856
Status: Offline
Location: Long Island
Drives: 2001 S-60 T5, Summer Ride 2002 Honda CBR 600F4I



Nothing,


Nothing happened. The lights turn on the indicators show but the gages don't work. Oh well at least it was only $20 for the try and the used DIM came with all new bulbs so all's well that ends well. B)
Go to the top of the page
 
QuoteReply
Dutch_Volvo_driv...
post Apr 21 2008, 04:12 PM
Post #12


Newbie


Group: Members
Posts: 1
Joined: 18-April 08
Member No.: 41,244
Status: Offline
Location: Netherlands
Drives: Volvo S60 D5, 2002



I am wondering if somebody tried the replacement of the electronic components already. I am driving a 2002 Volvo S60 D5 and having the same problems with the info display. I have some knowledge of electronics, but before I open the DIM, it would be nice to know where I have to search for.

In my case the info display is working in a "cold" situation. For about 10 minutes after starting I get the right information. After that the characters are moving around and it ends up with a complete blank info display.

It would be very helpful if somebody can explain more about this.

Thnks in advance.
Go to the top of the page
 
QuoteReply
romkaromka
post Apr 22 2008, 02:59 AM
Post #13


Newbie


Group: Members
Posts: 14
Joined: 13-April 07
Member No.: 26,952
Status: Offline
Location: ESTONIA
Drives: 2003 Volvo S60 D5



http://www.volvo-forums.com/t19793-dashboa...m-ecm-relay.htm

This is common problem of Volvo-s S60, V70, XC70 manufactured between 2001-2003.
The problem is in voltage regulator (L4925N) located in DIM. DIM manufacturer is Yazaki.
You need to replace this voltage regulator.
When you replace to new one make sure that connection with radiator is good. (use special paste, the same paste used in PC between radiator and processor)
Go to the top of the page
 
QuoteReply
macifre
post Apr 22 2008, 08:03 PM
Post #14


Newbie


Group: Members
Posts: 12
Joined: 25-May 06
Member No.: 15,106
Status: Offline
Location: Guatemala
Drives: 2001 S60 2.4T, 2002 MB CLK430 AMG



if you want to go with a used display you can do it, and it will show the milage the used one has on, I've done it already, it cost about $120... and then you'll need to reset the service airbag urgent message, or you can do this with the battery dissconected BEFORE you begin to work on the car and maybe this will save you the message reset...
Go to the top of the page
 
QuoteReply
romkaromka
post May 23 2008, 02:07 AM
Post #15


Newbie


Group: Members
Posts: 14
Joined: 13-April 07
Member No.: 26,952
Status: Offline
Location: ESTONIA
Drives: 2003 Volvo S60 D5



I have made some pictures of this problem:

Disassembled Volvo S60 DIM Panel

and second picture about broken voltage regulator:

Broken voltage regulator L4925N
Go to the top of the page
 
QuoteReply
budulan
post Jun 30 2008, 09:10 AM
Post #16


Newbie


Group: Members
Posts: 4
Joined: 6-September 07
Member No.: 32,247
Status: Offline
Location: Romania
Drives: Volvo S60



Hi to all. I`m from Romania and we have a Volvo forum too. We have also the problems with the Dimm. I search for approx. one year to solve the problem and I did!. The L4925N Volttage Regulator is not the problem if the display is lighting up. The L4925N is only for supply the voltage for the cips who control the display. I change him (I have a source for this) and the problem was stil there.
Soo, the problem is in the CIP (I will atach the pictures) and it can be solve very easy and will last for a good period of time. I dont know how to describe very well the procedure because I cant write so good in english, but I will do my best.
You have to blow with hot air the connections of the cipset because there is a contact problem and finaly to put a radiator over the cip to disipate the heat. The easy way is to go with the DIM on a repair shop for cell phones, usualy they have all the tools. I have all the tools and I solved at home. I will atach the pictures with the DIM and Good luck!
Go to the top of the page
 
QuoteReply
budulan
post Jun 30 2008, 09:12 AM
Post #17


Newbie


Group: Members
Posts: 4
Joined: 6-September 07
Member No.: 32,247
Status: Offline
Location: Romania
Drives: Volvo S60



Hi to all. I`m from Romania and we have a Volvo forum too. We have also the problems with the Dimm. I search for approx. one year to solve the problem and I did!. The L4925N Volttage Regulator is not the problem if the display is lighting up. The L4925N is only for supply the voltage for the cips who control the display. I change him (I have a source for this) and the problem was stil there.
Soo, the problem is in the CIP (I will atach the pictures) and it can be solve very easy and will last for a good period of time. I dont know how to describe very well the procedure because I cant write so good in english, but I will do my best.
You have to blow with hot air the connections of the cipset because there is a contact problem. The easy way is to go with the DIM on a repair shop for cell phones, usualy they have all the tools. I buy all the tools and I solved at home. I will atach the pictures with the DIM and Good luck!

Attached File(s)
Attached File  1.jpg ( 58.35K ) Number of downloads: 2642
Attached File  2.jpg ( 59.68K ) Number of downloads: 2649
Attached File  3.jpg ( 57.52K ) Number of downloads: 2398
Attached File  4.jpg ( 266.79K ) Number of downloads: 2352
Attached File  5.jpg ( 271.86K ) Number of downloads: 2279
Attached File  6.jpg ( 31.89K ) Number of downloads: 2036
 
Go to the top of the page
 
QuoteReply
feety
post Aug 19 2008, 05:41 PM
Post #18


Newbie


Group: Members
Posts: 1
Joined: 19-August 08
Member No.: 47,094
Status: Offline
Location: scotland
Drives: volvo s80



did u get your dash fixed
Go to the top of the page
 
QuoteReply
romkaromka
post Aug 30 2008, 12:18 PM
Post #19


Newbie


Group: Members
Posts: 14
Joined: 13-April 07
Member No.: 26,952
Status: Offline
Location: ESTONIA
Drives: 2003 Volvo S60 D5



HI!!!!!!
Today I have fixed second panel using Budulan method!
THIS METHOD WORKS REALLY WELL!!! (the problem is not in L4925N)
Please send this message to all forums and to all people who has this problem!
THE PROBLEM IN THE BAD CONNECTION OF MOTOROLA CHIP! You need to open driver panel, remove all indicators and then remove blue lacque (for example by acetone) from that chip and blow carefully all contacts with hot air. I have used aoyue 968 station and hot air with 350-400C temperature.

I post this picture again here!
This is a motorolla chip, selected by red color
http://www.loadmypicture.com/getimage.cgi?...4680.jpg&full=1

IF YOU HAVE PROBLEM WITH COMPUTER DISPLAY, TURN INDICATOR BLINKING, PANEL RESETS ITSELF, TIME TICKING ITSELF AND CAN'T STOP OR SOMETHING LIKE THIS ---- USE THIS METHOD AND YOU WILL FIX YOUR PANEL!
Go to the top of the page
 
QuoteReply
vmaxim
post Oct 22 2008, 05:47 AM
Post #20


Newbie


Group: Members
Posts: 1
Joined: 22-October 08
Member No.: 49,616
Status: Offline
Location: Norway
Drives: 2003 V70 D5



Anyone else tried this? I'm scared to try this because of the temperature, will 300-400'C
not melt the soldering around this chip? And are you 100% sure this chip is the problem
on computer-display flickering?
Go to the top of the page
 
QuoteReply
« Next Oldest 2009 and Below S60 Next Newest »
  Advanced Search

2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

6 Pages V   1 2 3 > » 
Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Dashboard Pin Code?
0 si s40 704 8th September 2013 - 03:32 PM
Last post by: si s40
No New Posts Dashboard Electrics
1 roman55 730 30th July 2013 - 10:52 PM
Last post by: danielm85948
No New Posts Dashboard Mileage Issue
0 rmikulec 422 26th June 2013 - 03:59 PM
Last post by: rmikulec
No New Posts Topic has attachmentsDashboard Conditioner
Recommended conditioner for 240 Volvo dashboard
1 Her-Man 480 10th March 2013 - 02:45 PM
Last post by: Kiss4aFrog
No New Posts Problems With Grom Usb2-plus
Startup problems
0 Emil889 896 3rd February 2013 - 11:53 AM
Last post by: Emil889

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 24th April 2014 - 02:11 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement