Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Hard Turn, Whirring Noise
Pentheos
post Feb 11 2007, 06:56 PM
Post #1


Member
*

Group: Members
Posts: 68
Joined: 10-September 06
Member No.: 19,589
Status: Offline
Location: Atlanta, Georgia
Drives: 2002 S60



Today I made a sharp, 180 degree turn, and my car began making a funny noise. The best I can describe is that it was a very loud whirring noise that got louder when I turned one way or another. I went to a parking lot and drove in some smaller circles, and then it got really loud, even when the car wasn't in motion and just idling.

So I looked under the hood. Seems the power steering fluid was low, so I put in about 2/3 of a small bottle, say 9 oz.

No more noise, nothing.

Would low powering steering fluid result in a loud noise like this? Why did it start after a hard turn? And will there be any residual damage?

And tomorrow, I am going to chew out the service manager at the local Volvo shop. I just had my car in there, and paid $40.00 for an oil change, during the course of which they should have checked fluids. (As soon as I pulled out of the mechanic that day, the windshield washer fluid ran out; I also had the wheels rotated, and they didn't adjust or check the tire pressure).
Go to the top of the page
 
QuoteReply
Rick Case
post Feb 12 2007, 09:31 AM
Post #2


Full Member
**

Group: Members
Posts: 138
Joined: 21-January 06
Member No.: 10,940
Status: Offline
Location: Jamaica
Drives: 2001 Volvo S60 T5 AW5



You did the right thing, if there is no fluid in the system the pump will take in air and lose it's differential pressure, you should have felt stiffness in the steering.

Please check if there is a leak in the system, check the low pressure hose clamp, I had to replace the factory clamp with an aftermarket clamp as the clamp gives way after a while. This could be a cause of your leak too.

There shouldn't be any residual damage.
Go to the top of the page
 
QuoteReply
volvoowner1
post Feb 12 2007, 12:46 PM
Post #3


Newbie


Group: Members
Posts: 8
Joined: 25-August 06
Member No.: 19,149
Status: Offline
Location: USA
Drives: 2003 Volvo S60 & S80



Wow, I just took my car into the shop for the exact same problem and they called me a few minutes ago and gave me the exact same explanation for the noise. They found a leak in my power steering fluid hose and I also was very low on power steering fluid. They are recommending a complete flush of the fluid (cost $115).

I got my 2003 S60 new in Feb 2003. I'm a little ticked because shortly after I got the car, I took it back to the dealer because it made that same noise on a couple of sharp left hand turns on downhill slopes. They said that they could not recreate the noise and did nothing for it. It was not until I started parking in a parking garage 2 years ago with very sharp turns that the noise started to occur more consistently. The last couple of weeks, it got so bad, I could no longer ignor it. (We have new tenants in our building and the garage is so full now that I usually have to park on the 8th or 9th level; with 4 tight turns per level, I was making as many as 72 tight turns per day!) In addition, I felt my steering wheel stiffen up. So the power steering explanation makes complete sense to me.
Go to the top of the page
 
QuoteReply
BiancaNeve
post Feb 15 2007, 09:42 PM
Post #4


Member
*

Group: Members
Posts: 60
Joined: 31-January 07
Member No.: 24,043
Status: Offline
Location: USA
Drives: 2003 Volvo S60 2.4L Manual



Same thing happened to mine. The hose had come loose, and the steering fluid was leaking.

The Volvo people took it out ALL day and could not recreate the noise. The mechanic just happened to open the hood and see that the tube had broken.

Cost me about 100 bucks.
Go to the top of the page
 
QuoteReply
FoCelestial
post Sep 20 2007, 05:14 PM
Post #5


Newbie


Group: Members
Posts: 10
Joined: 12-February 07
Member No.: 24,582
Status: Offline
Location: Faroe Islands
Drives: Renault 19 (Buying Volvo S60)



---
Go to the top of the page
 
QuoteReply
« Next Oldest 2009 and Below S60 Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Turn/hazard Replay
7 jhyman 7,074 8th December 2013 - 08:18 PM
Last post by: ppcgm
No New Posts Turn Signals Don't Work After New Battery Install
2 Jeb 2,047 17th May 2013 - 05:20 PM
Last post by: clickclack
No New Posts Noise?
after veh turned off
7 supero 1,380 26th March 2013 - 10:03 AM
Last post by: pfgym5
No New Posts Hard To Start With Strong Battery
3 cyrusyn01 437 19th March 2013 - 06:14 PM
Last post by: danielm85948
No New Posts Turn Signal Lens
need help replacing
1 Lawrence J 376 7th March 2013 - 08:12 PM
Last post by: Doogwhan

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 23rd July 2014 - 10:26 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement