Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Radio Problems After Detailing
greggjones
post Jan 3 2013, 12:48 PM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 3-January 13
Member No.: 113,916
Status: Offline
Location: us
Drives: 2002 V70 XC Ocean Race Edition



After having the car detailed, the standard HU-613 radio powers on when the car is started without pressing the power button and would not turn off. Only static was heard thru the speakers. The display on the radio did not include the CD and TAPE options, AM and FM only. The radio could be powered on and off only with the key in the ACC mode. Later the radio display showed the CD and TAPE options and now stays in TAPE mode switching between TAPE side A and side B. A tape is not in the player.

The detailers' claim that nothing was sprayed onto the radio. I'm wondering if excessive fluid may have run into the steering wheel controls or in the rear near the antenna connection? Any help is welcomed.
Go to the top of the page
 
QuoteReply
« Next Oldest 2G (2001-2007) V70, V70XC & XC70 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachmentsProblems With Dashboard Air Ducts
One has a fin loose and the other has foam and a yellow-white thing
0 qwertie64982 138 28th August 2014 - 05:07 PM
Last post by: qwertie64982
No New Posts Topic has attachmentsRadio Wires Messed Up
2 nicolie 389 17th July 2014 - 03:00 AM
Last post by: nicolie
No New Posts Radio Problem V50
0 volvov50chris 703 5th March 2014 - 04:10 PM
Last post by: volvov50chris
No New Posts Radio Repair
Premium Sound Presets not working
3 KJay 671 9th February 2014 - 05:45 PM
Last post by: KJay
No New Posts Radio Code Not Working
7 pixieisms 2,462 24th December 2013 - 08:37 AM
Last post by: NJV40

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 22nd October 2014 - 04:41 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement