Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2006 S40 Starting/stalling Issues
93240
post Jan 11 2013, 07:57 PM
Post #1


Newbie


Group: Members
Posts: 16
Joined: 20-June 05
Member No.: 5,623
Status: Offline
Location: Vancouver, BC, Canada
Drives: 1993 240



Hello,

My 06 S40 has been acting up. Two days ago I started the car and while driving to work it seems sluggish. I parked the car and turned it off. Tried to restart vehicle and the engine would not turn over. Took me several tries to get vehicle to start and proceeded to head for home. Vehicle stalled out a few times but I managed to limp it home. Shut down the car and waited a few minutes and it started fine but the check engine light came on. Tried a few more times and car started fine. Got out and checked gas cap and re-tightened it. Started car a few more times and check engine light went off.

Next day everything was fine. Car started and got to and from work fine. Today, car started fine and got to work. Went out for lunch and car started fine. However, came back to car and it would not start. When it did start it would sputter and stall out. Finally did get it started but had to rev the engine to do so and there was a strong fuel smell. Again limped it home with a stall out on the way. Got home and car again seems to start fine but check engine light is on again.

I have hardly driven my car in the last two year - 1500km added in last 8 mths. I think I only filled up 6 times in 2012. The last time I filled up (before today) was beginning of Dec 2012. Wondering if the gas could be the issue or if this could be some other fuel system related issue.
Go to the top of the page
 
QuoteReply
danielm85948
post Jan 11 2013, 09:05 PM
Post #2


Senior Veteran
***

Group: Members
Posts: 2,814
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (93240 @ Jan 11 2013, 08:57 PM)
Hello,

My 06 S40 has been acting up. Two days ago I started the car and while driving to work it seems sluggish. I parked the car and turned it off. Tried to restart vehicle and the engine would not turn over. Took me several tries to get vehicle to start and proceeded to head for home. Vehicle stalled out a few times but I managed to limp it home. Shut down the car and waited a few minutes and it started fine but the check engine light came on. Tried a few more times and car started fine. Got out and checked gas cap and re-tightened it. Started car a few more times and check engine light went off.

Next day everything was fine. Car started and got to and from work fine. Today, car started fine and got to work. Went out for lunch and car started fine. However, came back to car and it would not start. When it did start it would sputter and stall out. Finally did get it started but had to rev the engine to do so and there was a strong fuel smell. Again limped it home with a stall out on the way. Got home and car again seems to start fine but check engine light is on again.

I have hardly driven my car in the last two year - 1500km added in last 8 mths. I think I only filled up 6 times in 2012. The last time I filled up (before today) was beginning of Dec 2012. Wondering if the gas could be the issue or if this could be some other fuel system related issue.

first thing is get the codes, that will tell you if the trouble is your throttle control module is going bad that is at the side of your throttle,if no codes found, look on you tube on how to clean your throttle as it will be dirty due to your dirty breather system, that should be cleaned.clean with throttle cleaner for the throttle only.

This post has been edited by danielm85948: Jan 11 2013, 09:07 PM
Go to the top of the page
 
QuoteReply
Platypup
post Jan 11 2013, 09:50 PM
Post #3


Senior
***

Group: Members
Posts: 289
Joined: 6-February 07
Member No.: 24,285
Status: Offline
Location: Australia
Drives: Volvo V50 T5 AWD, Toyota RAV4, MG TC, Jaguar E-type



You could have water in the tank from condensation due to relative lack of use and humidity, or your last fill-up may have been with contaminated fuel. The water would normally settle in the bottom of the tank and move around with use of the car so the problem may be intermittent. Unfortunately there does not seem to be a convenient drain plug for the tank so you could try using "Drygas" from your automotive supplier to"absorb" any moisture in the tank and give the car a decent brisk run with fresh clean fuel in the tank.
Go to the top of the page
 
QuoteReply
93240
post Jan 15 2013, 10:43 PM
Post #4


Newbie


Group: Members
Posts: 16
Joined: 20-June 05
Member No.: 5,623
Status: Offline
Location: Vancouver, BC, Canada
Drives: 1993 240



Ok, here is an update. Ended up taking car into Volvo for servicing. Fault codes are ECM-250A, ECM-261A, ECM-3502, ECM-3503, ECM-2600. They indicated that the fuel pressure sensor reading was out by over 200KPA and replaced this part. Hopefully this addresses my issues.
Go to the top of the page
 
QuoteReply
« Next Oldest 2G (2004.5+) S40 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts 2006 C70 Cigarette Lighter
1 dancuthbertson 32 31st August 2014 - 07:15 AM
Last post by: grendel1960
No New Posts S40 Alarm And Mobiles ?!
1 BlackRain 113 18th August 2014 - 10:39 PM
Last post by: danielm85948
No New Posts Topic has attachmentsS40 Electric Problem
0 frost 406 29th May 2014 - 01:09 AM
Last post by: frost
No New Posts 2006 Xc90 2.5t - What To Check Before Buying ?
I am about to come on the XC90 side of the force.
1 Guinness9 532 28th March 2014 - 05:43 AM
Last post by: tpsells
No New Posts S40 Oil Trap/pcv Repair
Anyone done this?
2 dfagan261 1,314 27th February 2014 - 09:01 AM
Last post by: mf70

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 21st September 2014 - 01:09 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement