Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2003 S40 1.9l Turbo / Starting Issues, Seems to happen when the engine is cold
HCA
post Dec 12 2012, 11:43 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 12-December 12
Member No.: 113,488
Status: Offline
Location: USA
Drives: 2003 S40 4 cylinder 1.9L FI turbo



I have a 2003 Volvo S40 4 cyl. 1.9L FI Turbo which takes about 15 to 20 minutes to start sometimes.
Once it finally starts it may run really rough and you have to keep the engine revved up to keep it running, then it seems to run OK. After the engine is warm usually it will start again OK until I get off work and try to start it again. This morning was 32 Degrees outside and it started fine.(weird)
My check engine light came on so I took it by Oreilly's so they could diagnose and they came up with code P0107 which the Oreilly guy mentioned maybe "low pressure input" MAF ? Any suggestions?
Go to the top of the page
 
QuoteReply
« Next Oldest New Member Area/Introduction Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts S40 Alarm And Mobiles ?!
1 BlackRain 181 18th August 2014 - 10:39 PM
Last post by: danielm85948
No New Posts Turbo Adjustment
Auto 850, manual boost control, waste gate adjustment.?
1 Snabblåda 197 24th July 2014 - 10:45 PM
Last post by: danielm85948
No New Posts Turbo Charger Failure
3 JohnAnast 594 26th June 2014 - 10:15 AM
Last post by: danielm85948
No New Posts Topic has attachmentsS40 Electric Problem
0 frost 504 29th May 2014 - 01:09 AM
Last post by: frost
No New Posts 2003 Volvo S60 T5 Parts
part out will have more parts posted
0 crxej1 171 4th May 2014 - 09:15 AM
Last post by: crxej1

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 21st October 2014 - 10:11 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement