Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Side Mirror Adjustment Not Working, Electric side mirror issue
beauie
post Oct 2 2011, 05:23 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 2-October 11
Member No.: 96,214
Status: Offline
Location: Australia
Drives: 2003 XC90



The electric side mirror adjustment, L&R, (drivers side door armrest near window adjustment buttons) on my 2003 XC90 is not working. All other electrics are ok. Cannot seem to see a fuse for this circuit in the fuse box under the bonnet. Suggestions? Is there another fuse box perhaps?
Thanks for any suggestions.
Best,
Go to the top of the page
 
QuoteReply
ChrisG56
post Oct 13 2011, 08:11 PM
Post #2


Newbie


Group: Members
Posts: 1
Joined: 13-October 11
Member No.: 96,777
Status: Offline
Location: Webster Groves MO USA
Drives: 2007 Volvo XC90 AWD 3.2



Wish I had an answer but I dont - I do however have the same problem on my 2007 XC90... everything was just fine but all of a sudden both mirrors have stopped folding or moving... no lights on the little buttons when i press them...and the mirrors are sorta floppy... free to move in or out by hand they flop in slightly as I drive due to wind... all help/advice greatly appreciated

OK so immediately after I wrote the above I found the user manual (which I do not have) online - see link below
http://new.volvocars.com/ownersdocs/2007/2...90_09.htm#pg201
On the second fuse panel... to the left hand side of the dash (you need to pop the little hemispherical panel off) I removed fuses 5 and 6 for the power mirrors then fuse 12 for the upper ecm in that order. I turned on the ignition (dont know if this makes a difference) then turned it off again. I then replaced the fuses in the reverse order... whoopee... full functionality returned to the mirrors... moving and folding... good luck !!

(IMG:style_emoticons/default/grin.gif) (IMG:style_emoticons/default/thumbsup.gif) (IMG:style_emoticons/default/grin.gif) (IMG:style_emoticons/default/thumbsup.gif) (IMG:style_emoticons/default/grin.gif)
Go to the top of the page
 
QuoteReply
bjoroy
post Dec 7 2012, 02:08 AM
Post #3


Newbie


Group: Members
Posts: 15
Joined: 1-February 11
Member No.: 85,064
Status: Offline
Location: Norway
Drives: 2003 XC90 D5 AWD



This trick actually works! Same problem on my 2003. Removed 5, 6 and 12, ignition on, replace 12, 6, 5 and the mirrors starts working again :-) if you on the other hand place the 12-fuse in the 13-slot (which is a spare slot) you'll have a short moment of panic before you realize your mistake (IMG:style_emoticons/default/tongue.gif)
Go to the top of the page
 
QuoteReply
timboconqueso
post Jul 13 2015, 03:26 AM
Post #4


Newbie


Group: Members
Posts: 2
Joined: 13-July 15
Member No.: 152,282
Status: Offline
Location: South Korea
Drives: 2013 XC90



Hello everyone. Just wanted to let you know that I also had this problem this morning on my 2013 XC90. But slightly different symptoms and results.

* after a hard rain last night, when I started up the car this morning the automatic mirrors would not come back out from a stowed position
* all attempts to restart the car, turn random buttons off on the same panel did not fix the problem.
* all other electronics worked fine.
* fearing I would damage the mirrors, I put slight pressure on them to manually push them out but there was too much resistance so I just left them stowed.
* I drove to work with stowed mirrors (hyper vigilantly)
* I researched the problem and found this forum post. Planned to try the fuse trick after work.
* After work, went to the car, started it up... decided to test the mirrors first.
* mirrors worked fine. I didn't do anything differently.

I can only assume this is related to water, as the weather had cleared up and the mirrors had dried up by that point.
Go to the top of the page
 
QuoteReply
timboconqueso
post Jul 15 2015, 05:20 AM
Post #5


Newbie


Group: Members
Posts: 2
Joined: 13-July 15
Member No.: 152,282
Status: Offline
Location: South Korea
Drives: 2013 XC90



Update: today it did it again. Only this time there was no rain at all. Hot humid day. I pulled the fuses out and tried this trick several times with no success. I came back a short while later and turned the car on and just pushed the button. This time the drivers side mirror unfolded but the passenger one did not. I pushed the button again and the drivers side folded. I pushed it a third time and both came out.


When I arrived home I pulled all three fuses (5,6,12) and tested them with a multimeter. I noticed on one of the 25amp fuses, the connection was poor. Closer inspection revealed a slight film covering the leads of the fuses. I cleaned the tips of them off with a dry Brillo pad (being careful not to damage the soft metal of the leads) and tested them with the multimeter again. This time, I had perfect connectivity.

I put the fuses back in with the ignition turned off and heard a clunk sound in the door. Powered on the ignition and the mirrors work fine. I will keep monitoring and update appropriately. But if you never hear from me again, it's likely the cleaning of the fuse tips fixed my problem.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo XC90 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Not Starting After Heavy Rain
0 cooltony91 126 1st July 2015 - 09:14 PM
Last post by: cooltony91
No New Posts Not Starting After Heavy Rain
0 cooltony91 162 1st July 2015 - 08:09 PM
Last post by: cooltony91
No New Posts Not Start Without Any Messages.
0 Kikyoung 1,050 20th April 2014 - 02:36 AM
Last post by: Kikyoung
No New Posts Topic has attachmentsNot All Oil Filters Are Created Equal
Cut Open Filter for a 850
8 SeaMike 1,636 20th January 2014 - 11:31 PM
Last post by: Kiss4aFrog
No New Posts Mirror Light
What does it do?
2 _John_ 755 23rd October 2013 - 08:25 AM
Last post by: _John_

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 30th July 2015 - 03:09 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement