Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Rough, High Idle
toddmhale
post Nov 30 2012, 07:10 AM
Post #1


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



My 94 850 turbo wagon starts rough and idles very high. the rpms dont come down. After turning car off, wont restart again unless I let in sit for a while.
Go to the top of the page
 
QuoteReply
danielm85948
post Nov 30 2012, 08:25 AM
Post #2


Senior Veteran
***

Group: Members
Posts: 2,825
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (toddmhale @ Nov 30 2012, 08:10 AM)
My 94 850 turbo wagon starts rough and idles very high. the rpms dont come down. After turning car off, wont restart again unless I let in sit for a while.

clean both your idle control valve, and your butterfly on the throttle body , with carb cleaner or throttle body cleaner, just spray in to both the parts, as it is dirt and gum that is the trouble, but it sounds like you have more than this ,so change your fuel pump relay, just google these parts for details.
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 2 2012, 08:56 AM
Post #3


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



Cleaned icv and throttle body, no change. When I start the car the rpms just keep climbing, over 5000 if I let it go. Depressing the brake does nothing to stop the idle, just keeps climbing.
Go to the top of the page
 
QuoteReply
danielm85948
post Dec 2 2012, 05:07 PM
Post #4


Senior Veteran
***

Group: Members
Posts: 2,825
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (toddmhale @ Dec 2 2012, 08:56 AM)
Cleaned icv and throttle body, no change. When I start the car the rpms just keep climbing, over 5000 if I let it go. Depressing the brake does nothing to stop the idle, just keeps climbing.

check the hoses for a vacuum leak,and check the accelerator cable at the throttle, as it must be holding the butterfly in your throttle open.
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 3 2012, 08:57 AM
Post #5


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



I noticed that the intercooler outlet hose hose is very soft. No holes visible, but easy to squish between fingers. Could this possibly be the problem?
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 3 2012, 12:14 PM
Post #6


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



Have a code A2 4-1-1, throttle position sensor outside of voltage range? Could TPS be the problem?
Go to the top of the page
 
QuoteReply
danielm85948
post Dec 3 2012, 07:27 PM
Post #7


Senior Veteran
***

Group: Members
Posts: 2,825
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (toddmhale @ Dec 3 2012, 08:57 AM)
I noticed that the intercooler outlet hose hose is very soft. No holes visible, but easy to squish between fingers. Could this possibly be the problem?

yes take it off , will be pin holes replace it , or try repair it, a motorcycle repair kit you would be able to repair it, or try on ebay or car breakers.
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 4 2012, 08:17 AM
Post #8


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



QUOTE (danielm85948 @ Dec 3 2012, 07:27 PM)
yes take it off , will be pin holes replace it , or try repair it, a motorcycle repair kit you would be able to repair it, or try on ebay or car breakers.

Thanks. I will get new inlet and outlet hoses. You were also correct on throttle cable, tubing around cable is frayed and catching. What about the error code for TPS voltage out of range? Should I try a TPS from junk yard?
Thanks for your advice.
Go to the top of the page
 
QuoteReply
danielm85948
post Dec 5 2012, 09:53 AM
Post #9


Senior Veteran
***

Group: Members
Posts: 2,825
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (toddmhale @ Dec 4 2012, 08:17 AM)
Thanks. I will get new inlet and outlet hoses. You were also correct on throttle cable, tubing around cable is frayed and catching. What about the error code for TPS voltage out of range? Should I try a TPS from junk yard?
Thanks for your advice.

your TPS should be ok, as it may have been due to the butterfly being wide open ,so leave that part the now.
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 6 2012, 09:03 AM
Post #10


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



I think I finally found the problem. After trying to drive car, i found I have almost no brakes. I think it must be a vacuum leak in brake booster.
Go to the top of the page
 
QuoteReply
danielm85948
post Dec 6 2012, 09:07 AM
Post #11


Senior Veteran
***

Group: Members
Posts: 2,825
Joined: 2-July 10
Member No.: 74,889
Status: Offline
Location: glasgow uk
Drives: volvo 940 se turbo 1991



QUOTE (toddmhale @ Dec 6 2012, 10:03 AM)
I think I finally found the problem. After trying to drive car, i found I have almost no brakes. I think it must be a vacuum leak in brake booster.

check under the clip holding on your brake boaster rubber hose, may have a split in it.
Go to the top of the page
 
QuoteReply
toddmhale
post Dec 6 2012, 05:09 PM
Post #12


Newbie


Group: Members
Posts: 8
Joined: 22-November 12
Member No.: 113,019
Status: Offline
Location: usa
Drives: 1994 volvo 850 turbo wagon



Hose is fine and so is check valve, I think the booster is shot. I am having a hard time trying to find replacement insrtuction. There is a vacuum hose on firewall by brake booster that is not hooked up to anything, do you know where that should go? Thanks.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo 850 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Idle Rpm
linear actuator
0 cytashiro 496 22nd October 2013 - 04:23 PM
Last post by: cytashiro
No New Posts Rough Idle, Cylinder Misfires, Not Much Acceleration And More!
3 Scott13 907 20th October 2013 - 12:21 AM
Last post by: danielm85948
No New Posts Rough Idle, Surging, No Acceleration. Urgent Please Help
Rough idle, No acceleration, engine surging
3 Slicer89 1,171 2nd October 2013 - 01:25 AM
Last post by: mykael
No New Posts Rough Idle, Surging, No Acceleration. Urgent Please Help
Rough idle, No acceleration, engine surging
1 Slicer89 814 26th September 2013 - 08:22 PM
Last post by: Slicer89
No New Posts High Pitched Noise From Dashboard(?) 440
2 Mauriceh 1,290 1st September 2013 - 04:15 PM
Last post by: drainbamage

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 21st November 2014 - 01:56 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement