Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2005 V50 Se 2.0 Euro 4 Stereo Issue, Stereo has power but no sound
fraser.malcolm
post Jan 17 2013, 08:43 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 5-December 11
Member No.: 99,459
Status: Offline
Location: Aberdeen, Scotland
Drives: 2005 Volvo V50 SE Euro 4 Sportwagon



I have Volvo's factory fitted 'high performance stereo' in my volvo V50. For the last year the stereo has been cutting out (both CD and Radio), the power goes off to the display, sound stops and then immediately it goes back on. However, today the stereo cut off but the sound never came back on. The power is still going to the unit and I can still tune the stereo but there is no sound. All I can hear is a slight hum. The Cd's also don't work and I can't eject any of the CD's anymore.

Has anyone else had this problem. I'm having some problems with the electrics in the car, power to the doors sometimes drops out as a result of corrosion in the door pillar connectors. I was also told that water ingress into the fuse box is common in the Volvo V50's. Could this be related to the stereo issue.

Has anyone else had this problem and found a solution?
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo V50 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts 2006 C70 Cigarette Lighter
1 dancuthbertson 13 31st August 2014 - 07:15 AM
Last post by: grendel1960
No New Posts 2001 Volvo S40 For Sale (blown Engine)
1 S40 in Fla 46 24th August 2014 - 04:21 PM
Last post by: S40 in Fla
No New Posts V50 2.4i "whistling" Noise On Acceleration
1 tylerdean 61 23rd August 2014 - 02:54 AM
Last post by: Platypup
No New Posts 2011 Xc90 Dvd Display
Cracked screen
3 JPHen 52 22nd August 2014 - 05:25 PM
Last post by: JPHen
No New Posts Servicing The Volvo S60
The volvo is telling me to take for service
4 Grantgc 199 22nd August 2014 - 03:16 AM
Last post by: Grantgc

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 2nd September 2014 - 06:41 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement