Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> No Interior Lights, Trip Resets, Door Light On And No Alarm! Help?
ChiS40
post Nov 15 2012, 02:58 PM
Post #1


Newbie


Group: Members
Posts: 3
Joined: 15-November 12
Member No.: 112,778
Status: Offline
Location: Chicago, IL
Drives: 2004 Volvo S40 1.9T



I have a 2004 (1st gen) S40. Do not have the interior lights, the alarm does not sound, the door light is on the dash. I thought that it was the fuse so I checked it under the hood and it was blown. I tried replacing it but it explodes every time I put it in. I checked all the other fuses and they look fine (including the fuses under the drivers dash.

Anyone has any idea on what could that be or what should I check?

Thanks!
Go to the top of the page
 
QuoteReply
grendel1960
post Nov 15 2012, 05:02 PM
Post #2


Veteran
*****

Group: Members
Posts: 1,134
Joined: 25-June 06
Member No.: 16,314
Status: Offline
Location: Canterbury UK
Drives: 92 volvo 440, 91 volvo 940



central locking relay / unit,- that controls all those, when I got my v40 the central locking didnt work, the interior lights didnt work nor the alarm, when I looked one connector on the central locking relay had been disconnected, connecting it just set off the alarm, plus I had no remote for the locking.
I got a central locking relay and matched remote on ebay, plugged it in and everything worked again, because I bought a relay and remote that had already been matched there was no problem getting one reprogrammed to the other.
the door light worked correctly on mine so it may be worth checking that out for a short circuit on the switch.
Grendel
Go to the top of the page
 
QuoteReply
ChiS40
post Nov 25 2012, 10:56 AM
Post #3


Newbie


Group: Members
Posts: 3
Joined: 15-November 12
Member No.: 112,778
Status: Offline
Location: Chicago, IL
Drives: 2004 Volvo S40 1.9T



Thanks Grendel. That was exactly it. The central locking relay had a wire that came loose. I reconnected it and now is all working properly. I'm assuming that the wire being disconnected made the short somehow in the circuit and kept on blowing the fuse.

Again thanks for your help!!!!!!!

(IMG:style_emoticons/default/liebe011.gif)
Go to the top of the page
 
QuoteReply
« Next Oldest Interiors and Exteriors Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachmentsDoor Card/a Pillar/headliner Deterioration Solution!
how to repair for under $50
0 William47 85 21st September 2014 - 06:21 PM
Last post by: William47
No New Posts Only $150/day With Lift And Tool! Diy Garage Happy Hour Deal In September.
0 chrisww 100 31st August 2014 - 07:03 PM
Last post by: chrisww
No New Posts Topic has attachmentsNo Am Reception 2001 S60
6 mspopo 1,368 4th August 2014 - 08:19 PM
Last post by: YesNoMebbeSo
No New Posts Help! Throttle Actuator Stuck Open, Car In Limp Mode
1 deedatc 306 25th June 2014 - 05:20 PM
Last post by: danielm85948
No New Posts Help! Throttle Actuator Stuck Open, Car In Limp Mode
0 deedatc 174 25th June 2014 - 01:40 PM
Last post by: deedatc

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 21st October 2014 - 08:28 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement