Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> 2005 V50 Se 2.0 Euro 4 Stereo Issue, Stereo has power but no sound
fraser.malcolm
post Jan 17 2013, 08:43 AM
Post #1


Newbie


Group: Members
Posts: 1
Joined: 5-December 11
Member No.: 99,459
Status: Offline
Location: Aberdeen, Scotland
Drives: 2005 Volvo V50 SE Euro 4 Sportwagon



I have Volvo's factory fitted 'high performance stereo' in my volvo V50. For the last year the stereo has been cutting out (both CD and Radio), the power goes off to the display, sound stops and then immediately it goes back on. However, today the stereo cut off but the sound never came back on. The power is still going to the unit and I can still tune the stereo but there is no sound. All I can hear is a slight hum. The Cd's also don't work and I can't eject any of the CD's anymore.

Has anyone else had this problem. I'm having some problems with the electrics in the car, power to the doors sometimes drops out as a result of corrosion in the door pillar connectors. I was also told that water ingress into the fuse box is common in the Volvo V50's. Could this be related to the stereo issue.

Has anyone else had this problem and found a solution?
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo V50 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Several Advantages For Observance Movies
0 Anitakap20 32 23rd March 2015 - 04:24 AM
Last post by: Anitakap20
No New Posts 2004 S40 Starting Problem
Car will not start in hot weather
1 wpage1979 52 21st March 2015 - 01:29 AM
Last post by: danielm85948
No New Posts 2015 New Arrival Easycoding V1.2.0.150112 For Bmw And Rolls-royce Diagnose And Vehicle Personalized Setting Support Multi-languages
0 esldomino 25 20th March 2015 - 09:27 PM
Last post by: esldomino
No New Posts Serious Xc70 Problem
1 hdolyak 57 19th March 2015 - 01:05 PM
Last post by: danielm85948
No New Posts 2008 Volvo Xc90 Active Bi-xenon Headlights
0 JimmyD10N 46 14th March 2015 - 01:20 PM
Last post by: JimmyD10N

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 29th March 2015 - 05:22 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement