Welcome Guest ( Log In | Register )

Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Radio Problems After Detailing
post Jan 3 2013, 12:48 PM
Post #1


Group: Members
Posts: 1
Joined: 3-January 13
Member No.: 113,916
Status: Offline
Location: us
Drives: 2002 V70 XC Ocean Race Edition

After having the car detailed, the standard HU-613 radio powers on when the car is started without pressing the power button and would not turn off. Only static was heard thru the speakers. The display on the radio did not include the CD and TAPE options, AM and FM only. The radio could be powered on and off only with the key in the ACC mode. Later the radio display showed the CD and TAPE options and now stays in TAPE mode switching between TAPE side A and side B. A tape is not in the player.

The detailers' claim that nothing was sprayed onto the radio. I'm wondering if excessive fluid may have run into the steering wheel controls or in the rear near the antenna connection? Any help is welcomed.
Go to the top of the page
« Next Oldest 2G (2001-2007) V70, V70XC & XC70 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.


> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Topic has attachmentsAftermarket Engine Parts Surprise Around Black Friday
0 RitasRacing 8 Yesterday, 03:52 AM
Last post by: RitasRacing
No New Posts Radio Code For Volvo V40?
1 liside 53 11th November 2015 - 10:16 AM
Last post by: danielm85948
No New Posts Problems With Swm, Possibly?
No turn signal, no cruise control, no high beam.
8 murta 125 20th October 2015 - 02:16 AM
Last post by: murta
No New Posts Aftermarket Wire Harness For 2008 S60 With Premium Sound
0 Bishopk 111 25th August 2015 - 01:01 PM
Last post by: Bishopk
No New Posts Problems With A Volvo C70 Stuck In Park!?
1 bemshawn 209 21st August 2015 - 10:33 PM
Last post by: danielm85948

> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
Time is now: 25th November 2015 - 05:14 AM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement