Welcome Guest ( Log In | Register )


Hello, we have answers for your Volvo-related questions!. Why not take a few moments to ask a question, help provide a solution or just engage in a conversation with another member in any one of our forums. Together we can make our Volvo community a better place.
 
Reply to this topicStart new topic
Do you like Volvo-Forums.com? Link to us and help spread the word about our forum. Thanks!
> Help With Not Turning Off..., Ground? Ignition Switch? Alternator?
pete77gg
post Jan 7 2013, 03:02 PM
Post #1


Newbie


Group: Members
Posts: 3
Joined: 17-December 12
Member No.: 113,576
Status: Offline
Location: Charlotte, NC, USA
Drives: 1991 Volvo 240 Base Auto B230F



Thanks for your reply's guys! Well here it is...

Well, I've figured some things out but still have a question or two I could use some help with. So I got out the test light and found that there was only a dim glow when applied to the Oil Pressure Sending Unit (**** Light, Not gauge) wire. I found that when I either 1) ran a wire directly from battery to the Oil Pressure Sending Unit or 2) Unplugged the oil sending wire I could start the car. If I reattached it, just turns over and over. So while I do not fully understand why, I figured out the Starting issue. The car still continues to run (and overdrive light turns on for some reason...?) when I turn off the car & remove the key. (I have to pull the Fuel Pump fuse and then turn the key to "Off" position and it will shut off as it should.

Some have suggested Ignition Switch. I have a replacement from the pull-a-part but don't want to go through changing it if you think the Oil Pressure wire (Someone said that the Oil Pressure it is a grounding wire & that's why it tells the **** light to light up when improperly working?) may be the culprit? Or another possibility (Alternator backfeeding due to bad diodes etc.- even though the O'Reilly tester reads good alt & good diodes?)

Well here are my questions:
1) Is there a way to test if it is the Ignition Switch without the PTA removal?
2) If removal is needed, any tips? (Looks like a hell of a tight spot, upside down with a screwdriver or removing the instrument cluster- fooling with more old wires and potential screwups as a result...
3) Do you think the "Not shutting off" may have to do with the Oil Pressure wire? How to rewire it or reattach it if so?
4) Alternator bad (don't test the O'reilly testing unit basically)

Thanks a lot guys. Again.
Go to the top of the page
 
QuoteReply
« Next Oldest Volvo 240, 242, 244 & 245 Forum Next Newest »
  Advanced Search

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Reply to this topicStart new topic
Get your Volvo listed in the Garage Today, for FREE, to share with the world what you drive and what toys and modifications you have.

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts Help! Throttle Actuator Stuck Open, Car In Limp Mode
1 deedatc 308 25th June 2014 - 05:20 PM
Last post by: danielm85948
No New Posts Help! Throttle Actuator Stuck Open, Car In Limp Mode
0 deedatc 177 25th June 2014 - 01:40 PM
Last post by: deedatc
No New Posts Not Start Without Any Messages.
0 Kikyoung 476 20th April 2014 - 02:36 AM
Last post by: Kikyoung
No New Posts Topic has attachmentsHelp Finding The Camshaft Position Sensor
2 BenBiehl 537 9th February 2014 - 10:34 PM
Last post by: BenBiehl
No New Posts Topic has attachmentsNot All Oil Filters Are Created Equal
Cut Open Filter for a 850
8 SeaMike 903 20th January 2014 - 11:31 PM
Last post by: Kiss4aFrog

 
> Link To Us
If you found our site useful please link to us <a href="http://www.volvo-forums.com">Volvo-Forums.com</a>.
 
Time is now: 22nd October 2014 - 07:38 PM
© 2004 Volvo-forums.com
Volvo-Forums.com is not affiliated with or endorsed by Volvo Car Corporation.
Privacy Statement